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Using the Paint, Shape
Drawing, and Eraser Tools
Introduction
Adobe Photoshop supplies you with all types of adjustment
and manipulation tools. In addition to image enhancement,
Photoshop can also be a powerful application for designing
from scratch. With the vast array of supplied brushes, tips,
and shape drawing tools, Photoshop helps you produce any
images, either enhanced or developed from scratch, that you
might need for virtually any conceivable project.
Brushes come in all sizes and shapes, and can be controlled with a mouse or drawing tablet. Since the shape of
the tip controls brush strokes, Photoshop gives you access to
several sets of predefined brush tip shapes, or you can create
your own customized sets. As for shape drawing tools,
Photoshop doesn't limit your creativity to just drawing circles
and squares; it gives you instant access to dozens of predefined shapes. You can even create and save your own custom
shapes. When it comes to Photoshop's paint and drawing
tools, your choices are limitless, based only on your knowledge of the available tools, and a creative imagination—the
more you know, the more you can do with Photoshop.
And, when all the drawing is said and done, there will be
a need for cleaning up. With the various Eraser tools that
Photoshop provides, you can make quick work of touching up
those small problem areas. Photoshop provides regular
eraser tools, eraser tools that erase to a definable edge, and
even eraser tools that target specific color values.
When enhancing an image, you might want to apply a
gradient. Gradients can be something as simple as black and
white, or as complex as one that contains the colors of the
rainbow. Gradients can be applied to an image by completely
covering the original image information, or they can be controlled through targeted selection, and creative uses of blending modes.

What You’ll Do
Understand Foreground and
Background Colors
Use the Brush and Brush Presets Panel
Modify the Brush Presets Panel
Select Brush Tip Sets
Adjust Brush Tips
Create and Save Customized Brush Tips
Work with the Brush, Airbrush, Mixed
Brush, and Pencil Tools

9

Work with Auto Erase
Work with the Line and Standard
Shape Tools
Work with the Custom Shape Tool
Create and Save Custom Shape Sets
Use the Paint Bucket Tool
Work with the Eraser Tools
Work with the Magic Eraser Tool
Create and Apply Gradients
Create and Save Customized Gradients
Use the Color Replacement Tool
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Understanding
Foreground and
Background Colors

The Foreground and Background colors, located near the bottom of the
toolbox, are Photoshop's way of identifying your primary painting color,
as well as the color Photoshop uses in conjunction with the
Background layer. When you select any of Photoshop's painting or
drawing tools, the color applied to the document will be the foreground
color—that's its purpose. Hence, it's sometimes referred to as
Photoshop's active color. The Background color serves several functions—its primary purpose is to instruct Photoshop how to handle erasing on the Background layer. When you use an eraser tool on a
Photoshop layer, by default, the pixels are converted to transparency.
However, when you use an eraser tool on the Background, something
different happens. Since the Background does not support transparency, it replaces the erased pixels with the current background
color.

Change the Active Foreground
and Background Colors
Use any of the following methods to
change the active foreground or
background colors:
◆

Color panel

Eyedropper
tool

Select the Eyedropper tool on the
toolbox, and then click anywhere
in the active document to change
the foreground color.
Swatches panel

Hold down the Alt (Win) or Option
(Mac) key, and then click to
change the background color.
◆

Click on a color swatch in the
Swatches panel to change the
foreground color.
Hold down the Ctrl (Win) or A
(Mac) key, and then click to
change the background color.

◆

Click the Foreground or
Background thumbnail to choose
the color's destination. Create a
color in the Color panel.

◆

Click the Foreground or
Background Color box to open the
Color Picker dialog box, select a
color or enter color values, and
then click OK.

216
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Use Default and Switch the
Foreground and
Background Colors
1

Click the Default Foreground and
Background Colors button to
revert the foreground and
background colors to their default
values of black and white.

2

Click the Switch Foreground and
Background Colors button to
switch current colors.
TIMESAVER Press D to
change the foreground and
background colors to their default
values of black and white, and
press X to switch the current
colors.

2
1

Did You Know?
You can add colors from the Color
Picker to the Swatches panel. Open
the Color Picker dialog box, select the
color you want to add to the Swatches
panel, click Add To Swatches, type a
name for the color, and then click OK.

For Your Information
Selecting Colors
In Windows, you can use the Color dialog box, which displays basic
and custom color squares and a color matrix with the full range of
colors in the color spectrum, to help you select a color. You can enter
RGB values for hue, saturation, and luminosity (also known as brightness) to specify a color. Hue is a pure color (one without tint or
shade); the name of the color (red, green, etc.) is measured by its
location on the color wheel. Saturation is a measure of how much
white is mixed in with the color. A fully saturated color has vivid
tones; a less saturated color is more of a washed-out pastel.
Luminosity is a measure of how much black is mixed with the color.
A very bright color contains little or no black. You can also change
the hue by moving the pointer in the color matrix box horizontally; you
can change the saturation by moving the pointer vertically, and the
luminosity by adjusting the slider to the right of the color matrix box.
On the Macintosh, you click one of the color modes and select a
color, using its controls. You can select RGB values by selecting the
color sliders at the top of the dialog box, then choosing RGB Sliders
from the pop-up menu, and dragging the Red, Green, and Blue sliders. Or, you can enter values (color numbers) to select a color. You
can select hue, saturation, and brightness (or luminosity) values by
selecting Color Sliders, choosing HSB Sliders, then dragging the sliders or entering your own values.
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Using the Brush and Brush Presets Panels
Photoshop's Brushes Panel in CS4 has been
split into two panels (New!)—Brush and Brush
Presets—in CS5. The Brush panel allows you
to create and select individual brushes, while
the Brush Presets panel allows you to select
and use predefined or custom brush tip sets
or individual brushes. In the Brush panel, the
current painting engine configuration, with
options such as Shape Dynamics, Scattering,
Texture, Dual Brush, and Color Dynamics,
gives you control over brushes in ways that
once were only available in programs like
Adobe Illustrator.

Brush panel

Brush tip thumbnails

To use the Brush or Brush Presets panel,
you first need to select a brush tool, or a tool
that requires the use of a brush, such as the
Eraser tool, chosen from the toolbox, and
then display the Brush or Brush Presets panel.
You can click the Window menu, and then
choose Brush or Brush Presets to display the
panel. You can also click Brush Panel button
(New!) on the Control panel (with a brush tool
selected) or Brush Presets panel, or click the
Brush Presets button on the Brush panel. The
brush engine has been improved for quicker
response, especially with a graphics tablet.

Brush Options button

Brush Presets panel

Painting engine
options

Brush Panel button

Selected brush

Preset brush tips
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Modifying the Brush
Presets Panel

Change the Brush Presets
Panel View
1

Select a Brush tool on the toolbox,
and then select the Brush Presets
panel.

2

Click the Brush Presets Options
button, and then select from the
available View options:

The Brush Presets panel (New!) comes in many forms; you can view
brushes as strokes, or you can choose thumbnails, or even text
descriptions. The form of the Brush Presets panel does not impact its
performance, only how you view the available brush tips. Choose the
version that best suits your current design needs, and then change the
view as needed. When you select a brush, it becomes the default for
that tool only. This gives you the ability to choose a default brush for
each of the brush-specific tools.

1
2
Stroke
Thumbnail
view

◆ Expanded View. Select to gain

access to painting engine
options: Brush Tips, Shape
Dynamics, Scattering, Texture,
Dual Brush, Color Dynamics,
and Other Dynamics.
◆ Text Only. Select to display all

Text
Only
view

brush tips by their names.
◆ Small Thumbnail. Select to

display all brush tips using a
small thumbnail.
◆ Large Thumbnail. Select to

display all brush tips using a
large thumbnail.
◆ Small List. Select to display all

brush tips by their names and
small thumbnail.

Small
List
view

◆ Large List. Select to display all

brush tips by their names and
large thumbnail.
◆ Stroke Thumbnail. Select to

display all brush tips with a
stroke. (This is useful in
determining how the brush will
look when applied in the
document.)
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Selecting Brush
Tip Sets

The Brush Preset panel (New!) comes with a wide variety of predefined brush tip sets, including natural bristle (New!), faux finish, and
special effect brushes. Each set organizes specific brush tips by name.
Since other Photoshop tools also use brush tips, it's important to have
the right tool (brush tip) for the right job. Using or making do with the
wrong brush tip is akin to digging a swimming pool with a teaspoon.
You wouldn't paint a portrait with a house-painting brush, so don't settle for anything less than the exact brush tip you need to get the job
done.

Select Brush Tip Sets
1

Select a Brush tool on the toolbox,
and then select the Brush Presets
panel.

2

Click the Brush Presets Options
button.

3

Click any of the predefined brush
sets.

4

Click OK.

1

2

This replaces the current brush
tips with the selected set, or you
can click Append to add them to
the current set.
3

Did You Know?
You can draw straight lines using
Photoshop's brush tools. Holding the
Shift key while dragging constrains the
brush to a 90-degree line. To draw a
straight line between two points, click
once in the document window, move
the mouse to another position, hold
down the Shift key, and then click a
second time. A straight line will be
drawn between the first and second
mouse clicks.

4
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Adjusting Brush
Tips

The left pane of the Brush panel provides a series of controls that let
you define how a brush tip is applied to the active image. Features such
as Brush Tip Shape, Scattering and Color Dynamics let you further customize your brush tips so you can create that specialized brush for all
your image enhancement needs.

Adjust a Brush Tip
1

Select a Brush tool on the toolbox,
and then select the Brush panel.

2

Click the Brush Options button,
and then click Expanded View.

3

Click to select a specific brush tip.

4

Select from the various Painting
Engine options:

4

3

◆ Brush Tip Shape. Lets you

Brush Tip Shape
options

modify the size, angle,
roundness, hardness, and
spacing of the brush tip. In
addition, you can flip the brush
shape along its x (left to right),
or y (top to bottom) axis.

Preview box
shows brush tip
settings

◆ Shape Dynamics. Lets you

randomly (jitter) generate
different sizes, angles, and
roundness for the brush tip.
◆ Scattering. Lets you randomly

scatter the shape. Options
include the ability to distribute
(Scatter) the shape, as you
draw, choose how many to use
(Count), and randomly change
the number (Count Jitter), as
you draw.

Other Dynamics
Dynamic

Purpose

Noise

Generates random noise in the brush tip
as you draw.

Wet Edges

Fades the edges of the drawn shape,
similar to running a watercolor brush
over a wet canvas.

Airbrush

Changes the Brush tool into an
Airbrush.

Smoothing

Applies anti-aliasing to the drawn
shapes, creating a smoother shape.

Protect Texture

Preserves texture pattern when applying brush presets.

◆ Texture. Lets you select a

predefined or custom texture,
in place of a solid color.
◆ Dual Brush. Lets you select a

second brush.
◆ Color Dynamics. Lets you key

off of the active foreground and
background colors.
◆ Other Dynamics. See Table.
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Adjusting Bristle
Brush Tips

Bristle brushes (New!) simulate the effects of painting with a natural
brush, such as watercolors and oils. When you use a bristle brush, it
paints with vectors to resemble a natural brush stroke. When you select
a bristle brush, you can set brush options, such as brush shape (either,
round or flat), brush size, length, density, thickness, and stiffness. If you
want to see a visual representation of your changes, use the Toggle the
Bristle Brush Preview button (New!) on the panel. When you use a
writing tablet and 6D pen, such as a Wacom Art Pen, with a bristle
brush, the pen responds to pressure, bearing, rotation, and tilt.

Adjust a Bristle Brush Tip
1

Select a Brush tool on the toolbox,
and then select the Brush panel.

2

Click to select a bristle brush tip.

3

To show or hide the bristle brush
preview, click the Toggle the
Bristle Brush Preview button on
the panel.

4

Select from the various bristle
options:

1

2

4

◆ Shape. Lets you select a bristle

brush shape, such as Round or
Flat (Point, Blunt, Curve, Angle,
or Fan).
◆ Bristles. Lets you modify the

density of the bristle between
1% and 100%. The density is
the number of bristles in a
specified area of the brush
neck.
◆ Length. Lets you modify the

length of the bristle between
25% and 500%.
◆ Thickness. Lets you modify the

thickness of the bristle from
fine to coarse between 1% and
200%.
◆ Stiffness. Specify the rigidness

of the bristle between 1% to
100%. A lower value creates
flexible bristles, while a higher
value creates stiffer bristles.
◆ Angle. Lets you modify the

angle of the brush.
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Creating Customized
Brush Tips

Although Photoshop's Brush panel gives you many choices for brush
tips, any good designer will tell you that no matter how many brush tips
you have, you'll always want more. For example, you're working on a
100-year-old photograph, and you need a specific brush to add hair
details to the blown-out areas of the image. You'll want to find a special
type of brush that literally creates the illusion of wavy hair and add it to
your collection of brush tips. Photoshop, in an effort to help keep you
organized, gives you the ability to create your very own customized
brush tips, and then save them later in organized sets.

Create a New Brush Tip
1

1

Open an image, scan an item, or
select any of Photoshop's painting
tools and create a shape for a new
brush tip.

2

IMPORTANT Since the color of
a brush is determined when the
brush tip is selected, create the
brush tip using black or shades of
gray.
2

Select the brush tip using any of
Photoshop's selection tools.
IMPORTANT Photoshop picks
up any pixel information in the
underlying layers, even white. If
you want the brush to have a
transparent background, make
sure the areas surrounding the
image are transparent.

3

Click the Edit menu, and then click
Define Brush Preset.

4

Enter a name for the new brush
preset.

5

Click OK.

Layer with new brush tip

Open the Brush panel, and then
scroll to the bottom of the list to
access your newly created brush
tip.

5

Since the Define Brush Preset
button picks up any background
colors within the selection area, it
always creates the brush tip in a
blank layer.

4
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Saving Customized
Brush Tips

Once a brush tip is created, it becomes part of the current set.
However, the brush has not yet been permanently saved in Photoshop.
Although the new brush tip will reappear every time you access the
Brush panel, if you choose the option to reset the panel, the new brush
will be lost. To keep brushes you must save them into customized sets;
choose the default Brushes folder, so Photoshop can use them.

Save a Customized Brush Tip
1

Select a Brush tool on the toolbox,
and then select the Brush Presets
panel.

2

Create a set of customized
brushes.

3

Click the Brush Presets Options
button, and then click Save
Brushes.

4

Type the name of the set (with a
ABR extension).

5

Click the Save In (Win) or Where
(Mac) list arrow, and then select
where you want to save the brush
set.

6

Click Save.

3

2

Did You Know?

4

You can access your customized sets
directly from the Brush Options menu.
When you save your customized brush
set, put them in the Brushes folder,
located in the Adobe Photoshop
CS5/Presets folder. Brush sets saved
here appear in the Brush Options menu
along with the other Photoshop presets.

5

6
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Working with the
Brush and Airbrush
Tools

Photoshop's Brush and Airbrush tools were designed to reproduce the
visual effect of applying paint to a canvas. You have full control over the
brush tip, color, size, opacity, and even the brush's blending mode.
Control over the image is achieved by using additional layers to hold the
brush strokes—but remember, adding additional layers increases the
file size of a Photoshop document. Since layers have their own individual options, such as opacity, fill, and blending modes, you achieve even
greater control over the final design by giving brush strokes their own
layers. Once the brush stroke is to your liking, you can always merge
the brush-stroke layer into the image to conserve file size.

Work with the Brush and
Airbrush Tools
1

Select the Brush tool on the
toolbox.

2

Select a brush tip on the Options
bar or from the Brush panel.

3

Specify Paint Engine options for
the brush from the Brush panel.

4

Select from the following Brush
options on the Options bar:

2

4

1

Traced
with a 50%
Opacity
Paint
Brush.

◆ Mode. Click the list arrow to

choose from the available
blending modes. The blending
modes controls how the active
brush color blends with the
colors in the active image.
◆ Opacity. Enter an opacity

percent (1% to 100%), or click
the list arrow, and then drag
the slider left or right.

For Your Information

◆ Flow. Enter a flow percentage

(1% to 100%), or click the list
arrow, and then drag the slider
left or right. When you apply
the brush, Flow controls the
amount of ink supplied to the
brush.
◆ Airbrush. Click the button to

change the Brush into an
Airbrush.
5

Drag within the image to paint.

Using the Brush and Airbrush Tools
The Brush and Airbrush tools look the same, but they perform quite
differently. The Brush tool maintains a specific opacity; for example,
if you choose 50% opacity, the Brush maintains that opacity no matter how many times you pick up your pen and start again. However,
if you release and drag again over the same area, the Brush adds
another 50% application of ink to the image, producing a more saturated result. The Airbrush tool works by accumulation—dragging the
image produces a brush stroke based on the opacity of the brush
and the speed with which you move the tool across the image. If you
hold the Airbrush tool in one position, the ink color will slowly
increase until it reaches 100%, just like a real airbrush.
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Working with the
Mixed Brush Tool

With the Mixed Brush tool (New!), you can define multiple colors on a
single brush tip, and then mix and blend them together with the underlying hues on your canvas. With a photo, you can use a dry, empty brush
to blend the existing colors while at the same time adding a painting
effect to the image. Mixer Brush options on the Control panel allow you
to control the wetness of the brush, the load rate to add paint to the
brush, the mixing rate between the brush and canvas color, and
whether the brush is refilled, cleaned, or both after each painting stroke.

Work with the Mixed Brush Tool
1

Select the Mixed Brush tool on the
toolbox.

2

Select a brush tip on the Options
bar or from the Brush panel.

3

Select a mixing color.

4

Click the Current Brush Load list
arrow, and then select Load Brush,
Clean Brush, or Load Solid Colors
Only.

5

Click the Load the Brush After
Each Stroke or Clear the Brush
After Each Stroke button.

6

Click the Blending Combinations
list arrow, and then select a
preset.

7

Specify a percentage (1% to
100%), or click the list arrow, and
then drag the slider for any of the
following Mixed Brush options on
the Options bar:
◆ Wet. Controls the wetness of

the brush.
◆ Load. Controls the load rate to

add paint to the brush.
◆ Mix. Controls the mix rate

between the brush and canvas
color.
◆ Flow. Controls the amount of

ink supplied to the brush.
8

226
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7
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Working with the
Pencil Tool

The Pencil tool is exactly what its name implies…a pencil. The Pencil
tool is limited to hard brush tips of any size or shape, and creates
freeform lines using the current foreground color. In fact, the major difference between the Pencil and Brush tools is the Pencil tool's inability
to draw anything but a hard-edged line. A unique feature of the Pencil
tool is its ability to switch between the current foreground and background colors using the Auto Erase feature.

Work with the Pencil Tool
1

Select the Pencil tool on the
toolbox.

2

Click the Brush Preset Picker list
arrow, and then click a brush tip.

3

Click the Mode list arrow, and then
select a blending mode.

4

Enter an Opacity percentage value
(1% to 100%).

5

Drag the Pencil tool across the
active document.

2

3

4

1

5

Did You Know?
You can use the Pencil tool to create
calligraphy lettering. Select the Pencil
tool, click black as your painting color,
and then click one of the oblong brush
tips on the Options bar. If you own a
drawing tablet, use the tablet with the
Pencil tool to create beautifully formed
calligraphy letters.
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Working with
Auto Erase

The Auto Erase feature lets you automatically switch the Pencil tool's
painting color using the current foreground and background color
swatches. The trick is where you start drawing the line. If you start
dragging the brush tip from a new location in the document, the Pencil
tool creates a line in the active foreground color. If you then place the
brush tip on a previously drawn line and drag, the Pencil tool creates a
new line in the active background color. Since the Auto Erase feature
doesn't really erase anything, it will perform exactly the same way on a
transparent layer as it does on the background layer.

Work with Auto Erase
1

Select the Pencil tool on the
toolbox.

2

Select the Auto Erase check box
on the Options bar.

3

Drag the Pencil tool across the
active document to create a line in
the active foreground color.

4

Click anywhere in the background
and the Pencil tool will use the
foreground color.

5

Move the brush tip over one of the
previous lines, and then drag to
create a line in the active
background color.

2
1

Did You Know?
You can draw straight lines with the
Pencil tool. Click once in the document
to create a black dot, move to another
position, hold down the Shift key, and
then click again. When you hold down
the Shift key, the Pencil tool creates a
straight line between the two mouse
clicks.

3

4
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Working with the
Line Tool

The Line tool lets you draw lines by dragging from one point in the
active document and releasing in another. You can draw lines at precise 45- or 90-degree angles by holding down the Shift key as you drag.
Select the Line tool, or if you already have another drawing tool
selected, you can choose the Line tool from the toolbox. Then configure
the Line tool using the Options bar. It's also a good idea to create the
lines in a separate layer. That way, once the lines have been drawn, it's
as easy as selecting the Move tool and repositioning them where you
want them.

Work with the Line Tool
1

Select the Line tool on the toolbox.

2

Click the Fill Pixels button to
create raster shapes in the active
foreground color.

3

Click the Geometry options list
arrow, and then select from the
following options:

2

3

4

5

6

7

8

◆ Arrowheads. Select the Start

and/or End check boxes to
create arrowheads on the line.
◆ Width. Enter a percentage

(10 to 1,000), to determine the
width of the arrowhead in
relation to the width of the line.

1

◆ Length. Enter a percentage

(10 to 5,000), to determine the
length of the arrowhead.
◆ Concavity. Enter a percentage

(-50 to +50) to determine the
concavity of the arrowhead.
4

Enter a value (1 to 1,000 pixels) to
determine the weight of the line.

5

Click the Mode list arrow, and then
select a blending mode.

6

Enter an Opacity percentage value
(1% to 100%).

7

Select the Anti-alias check box to
create a visually smoother line.

8

Drag in the document window to
create the line.

For Your Information
Using the Line Tool
The Line tool can be used to create customized guidelines for those
projects that require something other than vertical or horizontal
guidelines. Just create a new layer, and then select the Line tool.
Choose a line weight (width) of one or two pixels, select a drawing
color that contrasts with the image, and then draw the required
guides. When you're finished, lock the layer, and use the visual
guides to complete your project. Hide the layer when it's not needed,
and finally, delete the layer when you're done with the job. One more
thing—remember to turn off the Arrowheads option.
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Using the Standard
Shape Tool

Creating standard shapes, such as polygons or rectangles with
rounded corners, used to be a hassle. That is, until Photoshop released
its Standard Shape drawing tools. Now, it's a simple matter of selecting
the correct tool, choosing a color, and then drawing the shape. As with
any of Photoshop's drawing functions, control is maintained with the
use of additional layers. Photoshop's standard shapes include rectangles, rounded rectangles, ellipses, and polygons. Each one of the shape
tools comes with additional options to control exactly how the shape
appears when drawn.

Work with the Standard
Shape Tool
1

Select the Rectangle, Rounded
Rectangle, Ellipse, or Polygon tool
on the toolbox.

2

Click the Fill Pixels button to
create raster shapes in the active
foreground color.

3

To switch tools, click the
Rectangle, Rounded Rectangle,
Ellipse, or Polygon tool buttons.

4

Click the Geometry options list
arrow, and then select from the
following drawing options or
check boxes:

2

3

1

◆ Unconstrained. (Rectangle,

Rounded Rectangle, Ellipse)
◆ Square. (Rectangle, Rounded

Rectangle)
◆ Circle. (Ellipse)
◆ Fixed Size. (Rectangle,

Rounded Rectangle, Ellipse)
◆ Proportional. (Rectangle,

Rounded Rectangle, Ellipse)
◆ From Center. (Rectangle,

Rounded Rectangle, Ellipse)
◆ Snap to Pixels. (Rectangle,

Rounded Rectangle)
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◆ Radius. (Polygon)
◆ Smooth Corners. (Polygon)

5

◆ Star. (Polygon)

6

7

◆ Indent Sides By. (Polygon)

8

◆ Smooth Indents. (Polygon)

5

Click the Mode list arrow, and then
select a blending mode.

6

Enter an Opacity percentage value
(1% to 100%).

7

Select the Anti-alias check box to
create a visually smoother image.
Useful when drawing shapes with
curved edges.

8

Drag in the document window to
create the shape.
IMPORTANT Maintain control
over your design by drawing
shapes in separate layers.

For Your Information
Using the Standard Shape Tool
Once a shape has been created, you can use Photoshop's extensive
layer effects options to colorize the shape, add a drop shadow or
bevel, or even apply a gradient or pattern to the shape. Remember
that in order to apply layer effects to the shape it must be isolated on
its own layer.
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Working with the
Custom Shape Tool

Having the ability to draw a perfect polygon or rounded-corner rectangle is nice; however, Photoshop went way beyond standard shapes
when it introduced the Custom Shape tool. Photoshop now comes
packaged with dozens of predesigned shapes, or you can even create
your own. User-defined shapes can be made from literally any vector
object. For example, a company logo can be converted to a custom
shape. Custom shapes have many time-saving applications. As previously mentioned, a company logo, if used frequently, is only a mouse
click away. Any vector form, outline, or shape used on a recurring
basis, can be converted to a custom shape and saved for future use.
Select the Custom Shape tool or, if you have any shape drawing tool
selected, click the Custom Shape button from the Options bar, and then
configure the shape using choices from the Options bar.

Work with the Custom
Shape Tool
1

Select the Custom Shape tool on
the toolbox.

2

Click the Fill Pixels button to
create raster shapes, using the
active foreground color.

3

Click the Geometry options list
arrow, and then select from the
available options: Unconstrained,
Defined Proportions, Defined Size,
Fixed Size, or From Center.

4

Click the Shape list arrow, and
then select a shape from the
available options.

5

Click the Mode list arrow, and then
select a blending mode.

6

Enter an Opacity percentage value
(1% to 100%).

7

Select the Anti-alias check box to
create a visually smoother line.

8

Drag in the document window to
create the customized shape.
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Creating a Custom
Shape

Custom shapes can be created from anything you choose, and the
process is quick and simple. You just create the shape, select the
shape, and name the shape. That's it. Since shapes are vector images,
they're resolution-independent, which means you can draw them at
any size without impacting image quality. Once custom shapes are
saved, they can be accessed by opening a document, selecting the
Shape tool, and choosing your new shape from the Custom Shapes
panel.

Create a Custom Shape
1

Open a document that contains
the vector image you want to
convert into a shape, or create a
shape using any of Photoshop's
vector drawing tools.

2

Click the Edit menu, and then click
Define Custom Shape.

3

Enter a name for the new shape.

4

Click OK.

1

The shape appears as a thumbnail
at the bottom of the active Custom
Shapes panel.

Did You Know?
You can move Photoshop shapes into
other vector programs, such as
Illustrator, FreeHand, and even Flash.
Click the File menu, point to Export, and
then click Paths To Illustrator. Name
the new document, and then click
Save.
Shape designed
in a Shape layer

3
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Saving Custom
Shape Sets

Creating customized sets of shapes is an excellent way to get organized. The next time you need a specific shape all you have to do is
select the shape from your organized sets. Organization can save you
time, but it also lends a sense of consistency to designs. Using the
same customized shapes repeatedly helps to tie the elements of a
design together, and Photoshop gives you the perfect way to maintain
that consistency with customized shape sets.

Save Custom Shape Sets
1

Select the Custom Shape tool on
the toolbox.

2

Click the Shape list arrow to see a
list of the current shapes.

3

Create new shapes, and then add
them to the current list.

5

2

1

IMPORTANT As you create
new shapes, if there are some you
don’t like, delete them. Right-click
the shape, and then click Delete
Shape.
4

To add preexisting shapes, click
the Options button, and then click
Load Shapes, or choose from the
available predefined shape lists.

5

Click the Options button, and then
click Save Shapes.

6

Enter a descriptive name for the
new set in the File Name (Win) or
the Save As (Mac) box.

7

Click the Save In (Win) list arrow
or Where (Mac) popup, and then
select a location to save the new
set.
IMPORTANT If you save the
new set in the Custom Shapes
folder, located in the Adobe
Photoshop CS5 application folder,
the new set will appear as a
predefined set when you click the
Shapes Options button.

8

Click Save.
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Using the Paint
Bucket Tool

The Paint Bucket tool is not new; in fact, it's been around almost as
long as Photoshop. The Paint Bucket's primary function is to fill an area
with the active foreground color, but that's not all it's capable of doing.
The Paint Bucket tool can fill areas with a selected pattern and, much
the same way that the Magic Wand tool selects image information, the
fill area can be controlled by the shift in brightness of image pixels.
Combine those features with the ability to change the Paint Bucket's
blending mode or opacity, and you have a tool with a lot of horsepower.

Use the Paint Bucket Tool
1

Select the Paint Bucket tool on the
toolbox.

2

Click the Fill list arrow, and then
select an option:

2

◆ Foreground. Fills a selected

4

3

5

1
7

8

area with the current
foreground color.
◆ Pattern. Fills a selected area

with a pattern.
3

Click the Pattern list arrow, and
then select a predefined fill
pattern. This option is available if
you select Pattern as a fill option.

4

Click the Mode list arrow, and then
select a blending mode.

5

Enter an Opacity percentage value
(1% to 100%).

6

Select a Tolerance value (0 to 255).
The Tolerance value influences the
range that the Paint Bucket uses
to fill a given area.

7

Select the Anti-alias check box to
create a visually smoother line.

8

Select the Contiguous check box
to restrict the fill to the selected
area.

9

6

9

10

Select the All Layers check box to
fill the color range information
from all the image’s layers.

10 Click the Paint Bucket tool cursor

on the area to be changed.
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Working with the
Eraser Tools

Photoshop's basic Eraser tool converts image pixels in a layer to transparent pixels. While the primary function of the Eraser tool has not
changed, the tool itself has been greatly improved. For example, you
can use the Eraser tool to remove a specific color or to erase around
the edge of an object. You can instruct the Eraser tool to remove a specific color while protecting another color and at the same time,
increase or decrease the tool's tolerance (the range of selection). If
you use the Eraser tool on a layered document, the tool will erase to
transparency. If the Eraser tool is used on a flattened document (flattened documents do not support transparency), the Eraser tool will use
the active background color to perform the erasure. As you can see,
the eraser tools do more than blindly erase image information. As you
master the eraser tools, you just may find those complicated eraser
jobs becoming easier and easier. The Background Eraser tool lets you
select specific colors within an image and erase just those colors.

Use the Basic Eraser Tool
1

Select the Eraser tool on the
toolbox.

2

Click the Brush list arrow, and then
select a brush tip.

3

Click the Mode list arrow, and then
select a blending mode.

4

Enter an Opacity percentage value
(1% to 100%) to determine how
much the eraser removes from the
image.

5

Enter a Flow percentage value
(1% to 100%) to determine the
length of the eraser stroke.

6

Click the Airbrush button to
change the solid eraser stroke of
the eraser to that of an airbrush.

7

Select the Erase To History check
box to temporarily turn the Eraser
into a History Brush.

8

Drag the Eraser over an image
layer to convert the image pixels
to transparency.
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Use the Background Eraser Tool
1

Select the Background Eraser tool
on the toolbox.

2

Click the Brush list arrow, and then
select a brush tip.

3

Click one of the Sampling buttons
(determines how the Background
Eraser selects the color range):
◆ Continuous. Continually selects

2

3

4

5

6

1

a color range as you drag the
Eraser tool across the image.
◆ Once. Samples a color range

when you first click your
mouse.
◆ Background Swatch. Only

erases the active background
color.
4

Click the Limits list arrow, and
then click how far you want the
erasing to spread:

7

◆ Discontiguous. Lets the Eraser

tool work with all similar color
range pixels throughout the
image.
◆ Contiguous. Restricts the

Eraser tool to the selected
color range, without moving
outside the originally sampled
area.
◆ Find Edges. Looks for a shift in

color range and attempts to
erase to the visual edge of the
image.
5

Select a Tolerance percentage
value (1% to 100%). The higher the
tolerance, the greater the range.

6

Select the Protect Foreground
Color check box to prevent that
color from being erased.

7

Drag in the image to erase.

For Your Information
Using the Background Eraser Tool
The Background Eraser tool erases an image by converting the
image pixels to transparency. If you attempt to use the Background
Eraser tool on a flattened image, the tool will automatically convert
the flattened background into a normal layer. Photoshop is actually
making an assumption that if you're using the Background Eraser
tool, you obviously need the image to be on a layer that supports
transparency, not a background layer.
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Working with the
Magic Eraser Tool

The Magic Eraser tool functions the same way as the Magic Wand
selection tool, except that instead of selecting an area, it erases it. The
Magic Eraser tool works on any traditional Photoshop layer, as well as
the Background layer. Clicking with the Magic Eraser tool converts
image pixels into transparent pixels. Since the Background layer does
not support transparency, using the Magic Eraser tool causes
Photoshop to convert the Background into a traditional layer.

Work with the Magic
Eraser Tool
1

Select the Magic Eraser tool on
the toolbox.

2

Enter a Tolerance value (0 to 255).
The higher the value, the greater
the range the Magic Eraser
erases.

3

Select the Anti-alias check box to
create a visually softer eraser
(useful when dealing with
intensely rounded or curved
selections).

4

Select the Contiguous check box
to select adjacent pixels within the
active document.

5

Select the Sample All Layers
check box to sample image
information from all layers
(Photoshop then treats the visual
image as a composite).

6

Click within the active document.
The Magic Eraser tool, depending
on the options you choose,
samples the pixels directly under
the tool and uses that data to
create a range for erasing image
information.
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Creating and Applying
Gradients

While most of Photoshop's painting and drawing tools let you select and
paint with a single color, the Gradient tool lets you paint with a veritable
rainbow of colors. The Gradient tool comes packaged with several sets
of predesigned gradients—including color, transparent, and neutral density (New!) options—or you can create and save your own customized
gradient sets. The process of creating a gradient is simple; you select a
gradient along with a specific type (Linear, Radial, etc.), and then drag in
the document window. The length and angle of the drag determines how
the gradient is applied. Since gradients, by default, overwrite image pixels, it's a good idea to create gradients in separate layers.

Create a Standard Gradient
1

Select the Gradient tool on the
toolbox.

2

Click the Gradient list arrow, and
then select from the available
gradients.

2

3

4

1

◆ The preset gradients include

Foreground to Transparent,
Chrome, Spectrum, Transparent
Rainbow, Transparent Stripes,
and Neutral Density (New!).
3

5

6

7

8

Select one of the following
gradient types from the five icons:
◆ Linear, Radial, Angle, Reflected

or Diamond.
4

Click the Mode list arrow, and then
select a blending mode.

5

Enter an Opacity percentage value
(1% to 100%).

6

Select the Reverse check box to
reverse the color order of the
selected gradient.

7

Select the Dither check box to
visually create a smoother
transition between gradient colors.

8

Select the Transparency check
box to create gradients using a
gradient mask (allows for
transparency in the gradient).

9

Drag in the image to create a
gradient.

9

For Your Information
Adding Predefined Gradients
To add a predefined gradient, you must first select the Gradient tool.
Click the Gradient Picker button, located on the Options bar, to use
one of the available gradient sets. Choose to append the new gradients to the existing list, or click OK to replace the existing gradients
with the new ones.
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Creating and Saving
Customized Gradients

Create and Save a Customized
Gradient
1

Select the Gradient tool on the
toolbox.

2

Click the thumbnail of the active
gradient on the Options bar to
open the Gradient dialog box.

3

Select a gradient from the
available options that is close to
what you want to create.

Customized gradients are easy to create and essential when you just
can't find what you want in Photoshop's predefined sets. It doesn't
matter how many gradients Photoshop provides for you, there will
always be that one instance where they just don't do the required job.
With just a few clicks of your mouse, you can create your own customized gradients. You can start with one of Photoshop's gradients and
modify it to your needs. You can also start completely from scratch; the
choice is yours, and so are the rewards of creating that one-of-a-kind
stunning gradient you can use for your current and future projects.

2

3

4

◆ The preset gradients include

Foreground to Transparent,
Chrome, Spectrum, Transparent
Rainbow, Transparent Stripes,
and Neutral Density (New!).

5

4

Enter a name for the new gradient.

6

5

Click New.
A thumbnail (copy of the selected
gradient) appears at the bottom of
the list.

6

Click the Gradient Type list arrow,
and then select one of the
following:
◆ Solid. Uses solid colors for the

gradient.
◆ Noise. Uses noise to distribute

the colors.
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Click the Smoothness list arrow,
and then select one of the
following:

8

◆ Smoothness. A percentage

14

value (0% to 100%) that
determines how smoothly the
colors of the gradient blend
together (available when the
Solid option is selected).

13

◆ Roughness. A percentage value

(0% to 100%) that determines
how much noise to introduce
into the gradient colors
(available when the Noise
option is selected).
8

9

7

To add Opacity Stops, click above
the gradient line; to remove
Opacity Stops, drag the stop away
from the line.
To add Color Stops, click below the
gradient line; to remove Color
Stops, drag the stop away from the
line.

12

9

11

10

10 Click on an Opacity Stop, and then

enter an Opacity percentage (0%
to 100%), and a Location
percentage (0% to 100%) for the
stop to place it on the line.

For Your Information

11 Click on a Color stop, and then

select a color, and a Location
percentage (0% to 100%) for the
stop to place it on the line.
12 Click Delete to delete the selected

opacity or color stop.
13 Click Save to save the new

gradient set.
The set will include the new
gradients, and all the gradients
that appear in the Presets panel.
14 Click OK.

Creating a Customized Gradient
Gradients serve many purposes. They can be used to jazz up a shape
drawn with Photoshop's drawing tools or they can be applied to an
entire document and used as a background on a web page,
brochure or newsletter. Whatever you use gradients for, remember
that they are powerful image elements. Use gradients to attract
attention to a document, but don't use them if they draw people's
eyes away from the main elements of the image. It will be a small
consolation to know that your fantastic marketing graphic attracted
attention, but everyone was so focused on your special effects and
gradients, they forgot to buy what you were selling. Remember, it's
always about the message. An image is worth a thousand
words…let the image tell its story.
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Using the Color
Replacement Tool

The Color Replacement tool lets you replace a specific color in your
image. For best results use soft brushes with this tool to help blend the
colors into the original image. Have you ever captured that perfect picture of a family member or friend, only to find they have red eyes? Or
maybe there's a part of your image where the color draws attention
away from the focal point. Either way, the Color Replacement tool is a
great feature that allows you to take control of the final image.

Use the Color Replacement Tool
1

Select the Color Replacement tool
on the toolbox.

2

Select a Brush tip on the Options
bar.

3

Select from the available Sampling
options:

1

◆ Continuous. Samples colors

continuously as you drag.
7

◆ Once. Replaces the targeted

color only where you click.
◆ Background Swatch. Erases

areas matching the background.
4

6

3

Select from the available Limits
options:
◆ Discontiguous. Replaces the

sampled color under the pointer.

2

4

5

◆ Contiguous. Replaces

connected areas containing the
sampled color and preserves
the sharpness of shape edges.
◆ Find edges. Limits painting of

the replacement color within an
object as defined by its edges.
5

Enter a Tolerance percentage value
(0% to 255%).

6

Select the Anti-alias check box for
a smoother edge on areas you
correct.

7

Select a foreground color to use to
replace the unwanted color.

8

Drag in the image over the color
you want to replace.
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Working with Objects
Introduction

What You’ll Do

Adobe Illustrator is an application that gives you great control
over vector graphics, which include vector shapes and vector
objects. Vector graphics are created using mathematical
shapes, not pixels, and that's why vector shapes are considered resolution-independent. When you draw a vector object,
you create one or more lines called a path. A path is made up
of one or more curved or straight line segments. The start and
end points for a line segment is known as an anchor point,
which you can drag to change and move.

Understand Vector and Raster Images

Illustrator provides drawing tools on the Tools panel that
you can use to create a variety of shapes, including rectangles, rounded rectangles, ellipses, polygons, stars, flares,
lines, arcs, spirals, rectangle grids, and polar (circular) grids.
After you draw an object, you can use Illustrator selection
tools to modify it. The two main selection tools are the
Selection tool and the Direct Selection tool. The Selection tool
allows you to select entire objects, while the Direct Selection
tool allows you to select paths and segments. In addition to
these tools, you can also use the Select menu. The Select
menu provides a variety of powerful selection commands for
you to use in a document or artboard. For example, you can
select objects whose attributes (including Appearance,
Blending Modes, Fill & Stroke, Opacity, and Stroke Color) are
similar to the current or last selection.

Create Line Segments

After you select one or more objects, you can move,
align, group, and transform them. The transformation tools
allow you to rotate, scale (resize), reflect (mirror image), or
shear (slant) an object.

Understand Paths
Select a Drawing Mode
Create Pixel Aligned Objects
Create Rectangle and Ellipses
Create Polygons and Stars

Create Arcs, Spirals, and Grids
Use the Shape Builder Tool

3

Create Perspective Objects
Use the Selection Tool
Use the Direct Selection Tool
Use the Lasso Tool

Use the Magic Wand Tool
Select and Group Objects
Save and Edit Selections
Move and Duplicate Objects
Align and Distribute Objects
Transform Objects

Rotate, Scale, Reflect, or Shear Objects
Apply Multiple Transformations
Reshape Objects with Envelopes
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Understanding Vector and Raster Graphics
Illustrator is an application that gives you
great control over vector graphics, which
include vector shapes and vector objects.
Vector graphics are created using mathematical shapes, not pixels, and that's why vector
shapes are considered resolution-independent. For example, if you enlarge a vector
image to 100 times its original size, Illustrator
merely changes the mathematical formulas to
reflect the new size, and since vector shapes
are constructed of mathematical data instead
of pixels, file sizes are extremely small.

Vector Image

Raster Image

Close up shows lines
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Raster graphics, such as bitmaps and photographs, are images creating using individual pixels that identify one piece of color
information. The reason raster images are
considered resolution-dependent is that once
the image is created or scanned, any enlargement of the image forces Illustrator to enlarge
and average the existing color information in
the document. This process, called interpolation, is what causes enlarged raster images to
become blurred, or pixelated.

Close up shows pixels
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Understanding Paths
When you draw an object, you create one or
more lines called a path. A path is made up of
one or more curved or straight lines, known
as segments. The start and end points for a
segment is called an anchor point. An anchor
point is a bending point to modify the line
segment. A path can be open or closed. An
open path has open-ended endpoints, such as
a line, while a closed path has connected endpoints, such as a circle. Paths can have two
types of anchor points: smooth points or corner points. A smooth point connects two
curved segments to create a smooth line,
while a corner point connects two straight or
curved segments to create a path direction
change. You can draw a path using both
smooth and corner points. The outline of a
path is called a stroke, which you can format
with different characteristics. You can specify
stroke weight (thickness), color, or a dashed
pattern. The interior of an open or closed path
is called a fill, which you can also format with
a color or gradient.

Working with Anchor Points
In Illustrator, you can show or hide anchor
points, direction lines, and direction points by
choosing the View menu, and then choosing
Show Edges or Hide Edges. If you want to
show or hide direction lines for selected
anchor points, select the Direct Selection tool,
select the anchor point that you want, and
then click Show Handles For Multiple Selected
Anchor Points or Hide Handles For Multiple
Selected Anchor Points button in the Control
panel.
You can specify options in the Selection &
Anchor Display preferences to always show
handles when multiple anchor points are
selected (this option is turned off by default).

Open path

You can change the shape of a path by
dragging its anchor point. A selected anchor
point or endpoint appears as a solid square,
while an unselected one appears as a white
square. When you select an anchor point
with a curved segment, a direction line
appears with direction points on each end,
which you can drag to change the shape of
the path. When you change the shape of a
smooth point with curved segments on each
side, both segments get changed. When you
change a shape of a corner point, the corner
is maintained, but adjusted based on the
change.

Closed path
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Selecting a Drawing
Mode

In Illustrator, you can specify how and where you want to draw an
object. You can draw on top of an object, behind an object, or inside an
object using one of the following drawing modes (New!): Draw Normal,
Draw Behind, or Draw Inside. Draw Normal mode is the default drawing
mode and the one used in previous versions of Illustrator. The Draw
Behind mode allows you to draw behind all objects on a selected layer
(no other objects selected). If an object is selected, the new object is
drawn directly behind it. The Draw Inside mode allows you to draw
inside a single selected object, which automatically creates a clipping
mask from the select object. You can select a drawing mode at the bottom of the Tools panel or use the Shift+D keyboard shortcut to cycle
through each one.

Select a Drawing Mode
1

Select the Drawing Mode tool on
the Tools panel:
◆ Draw Normal. Draws an object

Draw Inside

on top of any other object; the
default mode.

Draw Behind

◆ Draw Behind. Draws an object

Draw Normal

behind all objects (no selection)
or directly behind a selected
object.
◆ Draw Inside. Draws an object

inside a single selected object.
TIMESAVER Press Shift+D to
cycle through the Drawing Mode
tools.

1

Draw Normal

Did You Know?
You can create a clipping mask using
the Draw Inside mode. Select the path
you want to draw, and then click the
Draw Inside mode button on the Tools
panel. Subsequent paths are clipped
by the selected path until you switch to
the Draw Normal mode. The clipping
masks created using the Draw Inside
mode retain the appearance on the
clipping path unlike the Make command on the Clipping Mask submenu
on the Object menu.
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Creating Pixel Aligned
Objects

Work with Pixel Aligned
Objects
◆

Align All Objects in a New
Document. Click the File menu,
click New, specify new document
settings, select the Align New
Objects To Pixel Grid check box in
the Advanced section, and then
click OK.

◆

Align Existing Objects. Select the
object, open the Transform panel,
and then select the Align To Pixel
Grid check box.

◆

Not Align Objects. Select the
objects you want to change, click
the Select menu, point to Object,
and then click Not Aligned To
Pixel Grid.

◆

View The Pixel Grid. Click the
View menu, click Pixel Preview,
and then zoom to 600% or higher
(New!).

Pixel aligned vector objects (New!) allow you to create precisely drawn
images that look crisp and sharp for use on different outputs, such as
the Web and mobile devices. The Align to Pixel Grid option enables the
vertical and horizontal segments of the paths of an object to be nudged
and aligned to the pixel grid. The stroke width become full integer values to create crisp paths. To view the pixel grid, zoom to 600% or higher
in Pixel Preview mode. The Align to Pixel Grid option remains enabled
with the object until it’s disabled. You can set the option in the Advanced
section of the New Document dialog box or the Options menu on the
Transform panel. The option in the New Document dialog box, applies it
any new objects in the document. You cannot pixel-align objects without
paths, such as rasters, raster effects, and text objects.

Pixel Preview at 600%

Object aligned to pixel grid

Align To Pixel Grid option
in the Transform panel

◆ To set preferences for viewing

pixel grid, click the Illustrator
(Mac) or Edit (Win) menu, point
to Preferences, click Guides &
Grid, select the Show Pixel
Grid (Above 600% Zoom) check
box, and then click OK (New!).
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Creating Rectangles
and Ellipses

The Illustrator Tools panel includes several tools for quickly creating
simple geometric vector shapes. They are easy to use; you just click and
drag on the Stage to create the shapes. The Rectangle tool creates rectangles with square or rounded corners. The Ellipse tool creates circular
shapes such as ovals and circles. These shapes can be comprised
either of Strokes, which are lines that surround and define the shape, or
Fills, which can be a color or texture inside the shape, or both.

Draw an Ellipse or Circle
1

Select the Ellipse tool on the Tools
panel.
TIMESAVER Press L to select
the Ellipse tool.

2

Select a Stroke and Fill Color from
the Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse.
TIMESAVER Press and hold
Shift while you drag to create a
circle.

4

1

3

2

To create an oval or circle with a
specific width and height, click on
the artboard where you want the
top left corner, enter width and
height values, and then click OK.
4

Did You Know?
You can enter values ranging from 0 to
100 points in the Rounded Rectangle
Settings dialog box. A value of zero
gives you a straight-sided-square.
Higher numbers produce squares with
more rounded sides.
You can draw shapes without a stroke
or a fill. Set either of these properties
to No Fill in the Colors section of the
Tools panel or in the Color panel.
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Draw a Rectangle or Rounded
Rectangle
1

Click the Rectangle or Rounded
Rectangle tool on the Tools panel.

1

TIMESAVER Press M to select
the Rectangle tool.
2

Select a Stroke and Fill color from
the Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse.
TIMESAVER Press and hold
Shift while you drag to create a
square.

4

To create a square, rectangle, or
rounded rectangle with a specific
width and height, click on the
artboard where you want the top
left corner, enter width and height
values, and then click OK.

3

2

4

Did You Know?
You can change the corner radius for a
rounded rectangle. While you drag a
rounded rectangle, press the Up Arrow
or Down Arrow key. To create square
corners, press the Left Arrow key. To
create corners with maximum roundness, press the Right Arrow key.
You can draw shapes with no stroke
or fill. If you want to draw an oval or a
rectangle without a stroke or fill, you
can set either of these options to No
Fill in the Colors area of the Tools panel
or in the Color Mixer.
You can create a flare shape using the
Flare tool. Select the Flare tool on the
Tools panel, click and drag on the artboard, and then release the mouse.
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Creating Polygons
and Stars

The Polygon and Star tools work in much the same way as the Ellipse
and Rectangle tools do to allow you to easily create complex vector
shapes. You can use these tools to create either polygons or stars.
Polygons are shapes based on a center radius and a number of sides,
while stars are shapes based on two center radiuses: one for the distance from the center of the star to the innermost points, and another
for the distance from the center to the outermost points. Experiment
with several options to get the kind of shape you want.

Draw a Polygon or Star Shape
1

Select the Polygon or Star tool on
the Tools panel.
The pointer becomes a crosshair
that you can drag anywhere on the
artboard.

2

Select a Stroke and Fill color from
the Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse.
TIMESAVER Press and hold
Shift while you drag to create a
proportional shape.

4

To create a shape with a specific
radius and number of sides or
points, click on the artboard where
you want the center of the shape,
enter the following values, and
then click OK.

1

3

2

4

Polygon options

4

Star options

◆ Polygon. Enter a radius and

number of sides for the
polygon. To create a triangle,
enter 3 sides.
◆ Star. Enter radius 1 for the

distance from the center of the
star to the innermost points and
enter radius 2 for the distance
from the center to the
outermost points.
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Creating Line
Segments

The Line Segment tool draws perfectly straight lines in any direction
you drag your mouse. In Illustrator, a line is called a stroke and there is
a variety of thicknesses, styles, colors, and fills that can be applied to it.
You can also create your own line style for specific types of dashed,
dotted or artistic lines. You can constrain the path a line draws to 45degree angles or create closed shapes by intersecting the lines you
draw.

Draw a Line Segment
1

Click the Line Segment tool on the
Tools panel.
The pointer becomes a crosshair
that you can drag on the artboard.

1

TIMESAVER Press \ to select
the Line tool.
2

Select a Stroke color from the
Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse when
the line is the length you need.

3

2

TIMESAVER Hold down the
Shift key, and then drag to draw a
45, 90, or 180 degree line.
4

To create a line with a specific
length and angle, click on the
artboard where you want the line
to begin, enter length and angle
values, select the Fill Line check
box to fill the line with the current
fill color, and then click OK.

4
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Creating Arcs and
Spirals

The Arc and Spiral tools make it easy to create unique and interesting
shapes. These tools draw curved lines to create an individual arc or a
Spiral wind. An arc consists of an x and y axis length, open or closed
path, arc direction (known as the Base Along), arc slope, and arc fill
(optional). A Spiral consists of a radius from the center to the outermost
point in the Spiral, decay (the amount each wind decreases), number of
segments for the spiral, and Spiral style. Each full wind of a Spiral consists of four segments.

Draw an Arc
1

Click the Arc tool on the Tools
panel.
The pointer becomes a crosshair
that you can drag on the artboard.

2

Select a Stroke color from the
Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse when
the arc is the length you need.

4

To create an arc with specific
settings, click on the artboard
where you want the arc to begin,
enter x and y lengths, specify type
(open or closed), arc direction
(Base Along) and slope options,
select the Fill Arc check box to fill
the arc with the current fill color,
and then click OK.

1

3

2

4
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Draw a Spiral
1

Click the Spiral tool on the Tools
panel.
The pointer becomes a crosshair
that you can drag on the artboard.

2

Select a Stroke color from the
Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse when
the Spiral is the length you need.

4

To create a Spiral with specific
settings, click on the artboard
where you want the Spiral to
begin, enter a radius (distance)
from the center to the outermost
point, decay percentage (amount
of the wind decreases), the
number of segments, and style
options, and then click OK.

1

2

3

4
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Creating Grids

The grid tools on the Tools panel allow you to create a rectangular or
circular polar grid. The Rectangular Grid tool creates rectangular grids
of a specified size and number of horizontal and vertical dividers. The
Polar Grid tool creates concentric circles of a specified size and specific number of concentric and radial dividers.

Draw Rectangle Grids
1

Click the Rectangle Grid tool on
the Tools panel.
The pointer becomes a crosshair
that you can drag on the artboard.

2

Select a Stroke color from the
Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need.

4

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
horizontal and vertical dividers,
select the Use Outside Rectangle
As Frame check box to replace
individual segments with a
separate rectangle object, select
the Fill Grid check box to fill the
grid with the current fill color, and
then click OK.
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Draw Circular Polar Grids
1

Click the Polar Grid tool on the
Tools panel.
The pointer becomes a crosshair
that you can drag on the artboard.

2

1

Select a Stroke color from the
Colors area of the Tools panel.

3

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need.

4

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
concentric and radial dividers,
select the Create Compound Path
From Ellipses check box to
replace circles with separate
compound paths, select the Fill
Grid check box to fill the grid with
the current fill color, and then
click OK.

3

2

4
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Using the Shape
Builder Tool

The Shape Builder tool (New!) allows you to create complex objects
by merging and erasing simpler objects. The Shape Builder tool selects
edges and regions of an object, which can be merged or erased to form
a new object. An edge is any section of a path that doesn’t intersect
the path of other selected objects and a region is a closed area. You
can also break overlapping objects to create new ones. The style
attributes of an object are adopted after the merge. By default, the
Shape Builder tool is in merge mode, however, you can switch to erase
mode by using the Option (Mac) or Alt (Win) key. Before you start using
the Shape Builder tool, you can set up and customize options, such as
coloring source, highlighting, and gap detection, to suit your own
preferences.

Create an Object with the Shape
Builder Tool
1
1

Click the Selection tool on the
Tools panel, and then select only
the paths you want to merge to
create a shape.

2

Click the Shape Builder tool on the
Tools panel. By default, merge
mode is selected.

3

To break or extract a region from
the shape, click the selected
region.

4

To merge paths, drag along the
region.

2

Selected objects

The two regions get merged to
form a new shape. The attributes
from the region are applied to the
merging shapes.
3

TIMESAVER Press Shift as
you drag, displays a rectangle
marquee for merging multiple
paths.
5

To erase paths, press Option (Mac)
or Alt (Win) and click the closed
region or edge you want to delete.

4

5
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Set Shape Builder Tool Options
1

Double-click the Shape Builder
tool on the Tools panel.

2

To detect and show the gap
between objects, select the Gap
Detection check box, and then
select a Gap Length, either Small
(3 points), Medium (6 points), or
Large (12 points), or select the
Custom check box and specify a
point size length.

1

IMPORTANT Make sure the
gap length value is close to the
actual gap length, otherwise
Illustrator may not detect it.
3

Specify the Options and Highlight
settings you want:

2

◆ Consider Open Filled Path as

Closed. Select to create an
invisible edge for an open path
to make a region.

4

◆ In Merge Mode. Clicking

Stroke Splits the Path. Select
to split the parent path into two;
the first edge you click
specifies the split location.
◆ Pick Color From. Select Color

3

Swatches or Artwork as the
source for coloring objects. If
you select Color Swatches,
select the Cursor Swatch
Preview check box to preview
and select colors.
◆ Fill. Select to highlight the

merged area in gray or mouse
over the selected path.
◆ Highlight Stroke When

Editable. Select to highlight
strokes you can edit in the
color you select.
4

Click OK.
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Creating Perspective
Objects

The Perspective Grid tool (New!) allows you to display a perspective
grid that you can use to draw shapes and create scenes with 1, 2, or 3point perspective. For example, you can create a row of trees down a
street to create perspective. The perspective grid provides presets with
a 1, 2, or 3-point perspective to help you get started. You can change
the viewing angle and distance along with widgets to control vanishing
points, horizon height, ground level, and the origin. You can draw
objects directly on the perspective grid or attach existing ones to it. If
you want to match the depth or height of an existing perspective
object, you can use the Move Plane To Match Object command to
adjust the grid, so you can draw or adjust another object to it.

Draw Perspective Objects
1

Click the Perspective Grid tool on
the Tools panel.

1

2

◆ If the grid doesn’t appear, click

the View menu, point to
Perspective Grid, and then
click Show Grid.
2

To select a perspective grid
preset, click the View menu, point
to Perspective Grid, point to a
Point Perspective (One, Two, or
Three), and then select a preset.

3

To draw objects on the grid, do
any of the following:
◆ Draw Perspective Objects.

Select a Line tool (other than
the Flare tool) or Rectangle
tool, and then drag to draw it.
◆ Attach Normal Objects. Select

the plane to which you want to
use, select the normal object,
click the Object menu, point to
Perspective, and then click
Attach to Active Plane.
◆ Release Perspective Objects.

Select the attached object,
click the Object menu, point to
Perspective, and then click
Release with Perspective.
◆ Move Plane to Match Objects.

Select the existing object, click
the Object menu, point to
Perspective, and then click
Move Plane To Match Object.
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Adjust the Perspective Grid
1

Click the Perspective Grid tool on
the Tools panel.

1

2

Vertical Grid Extent

◆ If the grid doesn’t appear, click

the View menu, point to
Perspective Grid, and then click
Show Grid.
2

3

To select the active grid plane, click
a plane in the cube (Right, Left, or
Horizontal) in the Plane Switching
Widget. Click the area outside the
cube to select no plane.
To adjust the perspective grid, drag
the left or right controls on the grid
for any of the following:
◆ Ground Level. Moves the

perspective grid.
◆ Vanishing Points. Adjusts the

perspective in or out.

Horizon Level
Vanishing Point

Vanishing Point

Extent of Grid

Extent of Grid

Origin

Ground Level
Horizon Height
1 point perspective

Ground Level

Grid Cell Size

Grid Plane Controls

2 point perspective

◆ Horizon Height. Adjusts the

horizon line up or down.
◆ Extend the Grid. Extends or

shortens the perspective grid.
◆ Grid Plane Controls. Adjust the

Right, Horizontal, or Left.
◆ Grid Cell Size. Increases or

decreases the grid cell size.
◆ Origin. Adjusts the X and Y

coordinates of the grid plane.
4

To set perspective grid related
options, click the View menu, point
to Perspective Grid, and then click
any of the following:
◆ Show/Hide Rulers. Shows or

hides the ruler on the height line.
◆ Snap to Grid. Snaps an object to

3 point perspective

a perspective gridlines.
◆ Unlock/Lock Grid. Unlocks or

locks the perspective grid.
◆ Lock Station Point. Locks the

station point in place. When you
move one vanishing point, the
other one moves in sync.
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Working with
Perspective Objects

The Perspective Selection tool (New!) allows you to select, move,
scale, copy, and transform objects in perspective. You can also add normal objects, text, and symbols to the perspective grid. When you move
or change a normal object to the perspective grid, its appearance and
scale change to adhere to the grid. You can select perspective objects
in the grid with the Perspective Selection tool by clicking individual
objects or dragging a selection marquee, just like normal objects.

Modify Perspective Objects
1

Click the View menu, point to
Perspective Grid, and then click
Show Grid.

2

Click the Perspective Selection
tool on the Tools panel.

3

To work with perspective objects
on the grid, do any of the following:

2

◆ Move Perspective Objects.

Select the object, and then drag
it to another position or use the
Arrow keys. Press tilde (~) to
constrain the move to parallel.
◆ Move or Copy Perspective

Objects and Grid Plane.
Double-click a grid plane
control, click the Move All
Objects or Copy All Objects
option, click OK, and then drag
the grid plane control.

3

◆ Copy Perspective Objects.

Select the object, and then
Option+drag (Mac) or Alt+drag
(Win) it to another position.
◆ Resize Perspective Objects.

Select the object, and then drag
a resize handle.
◆ Add Normal Objects. Select the

active plane, and then drag the
normal object to the plane.
◆ Add Text and Symbols. Select

an existing normal text or
symbol, and then drag it on the
active plane. To modify the text
and symbols, use the Edit Text,
Edit Perspective, and Isolate
Selected Object buttons on the
Control panel.

78

Chapter 3

Three perspective object on the grid;
they were moved, copied and resized.

C03ILCS5.qxp

3/18/2010

8:18 PM

Page 79

Customizing a
Perspective Grid

If you create your own perspective grid, you save it as a preset (New!)
for use later. You can create a perspective grid by using the Define Grid
command to set exacting measurements and options or by manually
adjusting an existing grid, and then saving it as a preset, which you can
edit at any time. When you create or work with an existing perspective
grid, you can set grid options (New!) to show or hide the active plane
widget, change the widget position, and specify which points you want
to use to temporarily hide the active plane with the Shift key.

Set Perspective Grid Options
1

Double-lick the Perspective Grid
tool on the Tools panel.

2

Select the Show Active Plane
Widget check box to display it.

3

Click the Widget Position list
arrow, and then select a position.

4

Select the Anchor Point Of
Perspective Artwork or the
Intersection Of Gridlines check
boxes to specify the points where
you want to temporarily hide the
active plane with the Shift key.

5

2

3

5

4

Click OK.

Create a Perspective Grid Preset
1

Click the View menu, point to
Perspective Grid, and then click
Define Grid to create a grid (steps
3 thru 6) or manually create one.

2

Click the View menu, point to
Perspective Grid, and then click
Save Grid As Preset.

3

Type a name for the preset.

4

Specify the perspective grid
settings you want.

5

Specify the grid color & opacity
settings you want.

6

Click OK.

7

To edit a grid preset, click the Edit
menu, click Perspective Grid
Presets, select a preset, click Edit,
make changes, and then click OK.

3

6

4

5
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Understanding Selections
When you create vector graphics in Illustrator,
they are comprised of distinct segments that
can be selected separately or as a whole with
a variety of selection tools. The type of editing
you need to perform determines which tool
you use. For example, a simple rectangle is
comprised of four line segments that surround the contour of the shape and one fill in
the center. Each of these parts can be selected
as a group with the Selection tool or individually with the Direct Selection tool. To select an
object using the fill, you need to deselect the
Object Selection by Path Only check box in
Selection & Anchor Display preferences. If an
object is behind another object, you can use
the keyboard shortcut A+click (Mac) or
Ctrl+click (Win) to select it (New!). The pointer
changes to an arrow with a small caret on the
first A/Ctrl+click; as you continue to click the
selection moves through the objects under
the pointer. To use this option, you need to
select the Control Click to Select Objects
Behind check box in Selection & Anchor
Display preferences.

In addition to the Selection and Direct
Selection tools, you can also use the Group
Selection tool to select all the anchor points
on a single path. With the Group Selection
tool, click to select an object, click twice to
select the object’s group, and click three times
to select the group within the group (if available). The Group Selection tool is useful for
working with multiple objects. If you want to
work with an individual object without affecting other objects, it’s better to use Isolation
Mode.
The Lasso tool is a classic selection tool
that allows you to select path points and segments by dragging a freeform marquee
around them.
The Magic Wand tool allows you to select
objects of the same or a similar fill color,
stroke color, stroke weight, opacity, or blending mode.

Selection tool
Direct Selection tool

Selection preferences
Magic
Wand
tool
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Using the Selection
Tool

Select an Object with the
Selection Tool
1

There are several ways to select objects in Illustrator. With the
Selection tool, you can select an object's stroke or fill. You can only
select an object using the fill if the path appears in Preview mode, and
the Object Selection by Path Only check box is deselected in Selection
& Anchor Display preferences. After you select one or more objects,
you can add or subtract objects to/from the selection. In addition, you
can use the Selection tool and drag a marquee to select parts of the
object or drag over a portion of it to create a selection rectangle.

1

Click the Selection tool on the
Tools panel.
The pointer becomes an arrow.
TIMESAVER Press V to select
the Selection tool.

2

2

Position the arrow on the edge of
the object, and then click it.
◆ You can also drag a marquee

across all or part of the object
to select the entire path.
◆ If the path has a color fill,

appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.
3

3

To add or subtract objects from the
selection, hold down the Shift key,
and then click unselected objects
to add or click selected objects to
subtract them from the selection.
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Using the Direct
Selection Tool

Select Anchor Points and
Segments with the Direct
Selection Tool
1

With the Direct Selection tool, you can select individual points and segments of a path. After you select one or more individual points and segments, you can add or subtract items to/from the selection. In addition,
you can also use the Direct Selection tool and drag a marquee to select
parts of the path or drag over a portion of it to create a selection rectangle.

1

Click the Direct Selection tool on
the Tools panel.
The pointer becomes an arrow.
2

TIMESAVER Press A to select
the Direct Selection tool.
2

Position the arrow on the edge of
the path and click to select a
segment, and then click an anchor
point to select it.
◆ You can also select an anchor

point directly. Pass the pointer
over a path and then point to an
anchor point and then click it.
◆ You can also drag a marquee

across all or part of the object
to select the entire path.
3

82

To add or subtract anchor points
or segments from the selection,
hold down the Shift key, and then
click unselected items to add them
or selected items to subtract them
from the selection.
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Using the Lasso Tool

Use the Lasso tool when you want to select shapes that are very close
to shapes you don't want to select. This tool allows you to draw around
the shape, selecting everything contained within the drawn area. When
you draw a selection, you can drag across a path to include it in the
selection instead of dragging completely around it. This selection tool is
useful when you are working with overlapping paths.

Select with the Lasso Tool
1

Click the Lasso tool on the Tools
panel.

2

Draw around the shapes you want
to select.

3

To complete the selection, return
to the point where you started.

1

Did You Know?
You can select single or multiple
objects. Holding the Shift key adds line
segments and fills them. Shift-clicking
selected items deselects them.

2

3
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Using the Magic
Wand Tool

The Magic Wand tool (so named since it looks like a magic wand) is
unique in the fact that you do not drag and select with this tool; you
simply click. The Magic Wand tool creates a selection based on the
shift in brightness ranges within an image. If there is a definable shift in
the brightness of the pixels, it can be a very powerful tool for the selection of odd-shaped areas. To use the Magic Wand, click on the Magic
Wand Tool button on the Tools panel.

Select Options for the Magic
Wand Tool
1

1

Double-click the Magic Wand tool
on the Tools panel.
◆ You can also click the Window

menu, and then click Magic
Wand to display the panel.
2

Click the Options menu, and then
select the Show Stroke Options
and Show Transparency Options
(if necessary) to display them in
the Magic Wand panel.
◆ You can also click the double-

arrow next to the Magic Wand
title to display options.
3

4

5

6

84

Select the check box for the
attributes that you want the Magic
Wand to select. The options
include: Fill Color, Stroke Color,
Stroke Weight, Opacity, or
Blending Mode.

2

5

Enter a Tolerance value (0 to 255).
The higher the value, the more
information the Magic Wand tool
selects.
To select objects on all layers,
click the Options menu, and then
select Use All Layers to check it.
Select it again to select objects
only on the current layer.
To reset all fields in the Magic
Wand panel, click the Options
menu, and then click Reset.
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Use the Magic Wand Tool
1
2

Select the Magic Wand tool on the
Tools panel.

1

Click an object area to make a
selection.
Depending on the options you
selected in the Magic Wand panel,
other objects with the same or
similar attributes (fill color, stroke
color, stroke weight, opacity, or
blending mode) are selected.

3

To add to the selection, hold down
the Shift key, and then click
another unselected object.
To subtract from the selection,
hold down the Alt (Win) or Option
(Mac) key, and then click a
selected object.
2

3
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Selecting and
Grouping Objects

Selecting and grouping objects makes it easier to work with multiple
objects as if they were a single object. You can easily select, isolate,
cut, copy, paste, move, recolor, and transform a grouped object. You
can group all types of objects, yet still edit individual objects within the
group as needed without having to ungroup them first by using
Isolation Mode. Illustrator places a grouped object on the top level of
the top object in the group and uses the same selection color. If you no
longer need to group objects, you can ungroup them.

Create a Group
1

Select the Selection tool on the
Tools panel.

2

Use a selection method to select
the objects that you want in the
group.

3

Click the Objects menu, and then
click Group.

1

2

◆ You can use the Group

command again to group
objects already in a group; this
is known as a nested group.

Ungroup Objects
1

Select the Selection tool on the
Tools panel.

2

Select the grouped objects that
you want to ungroup.

3

Click the Objects menu, and then
click Ungroup.
◆ If you have nested groups

within an object, you can use
the Ungroup command again to
ungroup it.

86

Chapter 3

1

2

C03ILCS5.qxp

3/18/2010

8:21 PM

Page 87

Use Isolation Mode to Work
with Groups
1

Select the Selection tool on the
Tools panel.

2

Double-click a grouped object.

1

◆ You need to click the Isolate

Selected Group button on the
Control panel or select the
Double-click to Isolate check
box in General preferences.
A gray bar appears with the name
of the group at the top of the
document window. All objects
outside the group are dimmed out
and uneditable. The words
“Isolation Mode” also appear on
the Layers panel.
3

Edit individual objects or add new
objects to the group.

4

To exit Isolation Mode, click the
gray bar.

4

2

3
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Selecting Similar
Objects

Use the Select Menu to Select
Objects
1

Click the Select menu.

2

Select the command that you
want:
◆ All. Selects all objects in the

document.
◆ All on Active Artboard. Selects

all objects in the active
artboard.
◆ Deselect. Deselects all objects

in the document.
◆ Reselect. Reselects the most

recent selection.
◆ Inverse. Inverses the current

selection.
◆ Next Object Above. Selects the

next object above the current
selection.
◆ Next Object Below. Selects the

next object below the current
selection.

88
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The Select menu provides a variety of powerful selection commands
for you to use in a document or artboard. In addition to the common
commands, such as All, Deselect, and Inverse, you can also select
objects whose attributes (including Appearance, Blending Modes, Fill &
Stroke, Opacity, and Stroke Color) are similar to the current or last
selection. For more selection power, you can select objects based on
the object type (including All on Same Layers, Direction Handles, Brush
Strokes, Clipping Masks, Stray Points, Text Objects).
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Select Similar Objects or Object
Attributes
1

Select an object on which to base
the new selection or deselect all
objects to base the new selection
on the last selected object.

2

Click the Select menu, and then
point to Same or Object.

3

Choose the command that you
want to use to make a selection.

3
2

Select Objects in the Layers
Panel
1

Open the Layers panel.

2

Click the expand/collapse triangle
to display the layer that you want
to select.

3

Click the selection area on the
right side of the layer in the Layers
panel that has the object that you
want to select.

1

3

◆ You can also click the Select

menu, point to Object, and then
click All on Same Layers to
select all on a layer.

2
Selection
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Saving and Editing
Selections

If you frequently select the same elements in a document, you can save
yourself some time by saving the selection with a name of your choice.
After you save a selection, the saved selection name appears as a
menu command at the bottom of the Select menu. When you need to
make the same selection, simply choose the command. When you no
longer use a saved selection, you can delete it.

Save and Use a Selection
1

Make the selection that you want
to save.

2

Click the Select menu, and then
click Save Selection.

3

Enter a name for the selection.

4

Click OK.

5

Click the Select menu, and then
click the name of the saved
selection at the bottom of the
menu.

3

4

5

Edit a Saved Selection
1

Click the Select menu, and then
click Edit Selection.

2

Select the saved selection that
you want to rename or delete.

3

To delete a saved selection, click
Delete.

4

To rename a saved selection,
change the name in the Name box.

5

Click OK.

2

5

3

4
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Moving Objects

Moving an object or group of objects is very easy. The simplest way is
to drag the edge of an object in Outline or Preview view. If you want to
constrain the movement of the object in multiples of 45 degrees, then
use the Shift key as you drag. While you drag an object, Smart Guides
appear automatically to make it easier for you to align objects with
other objects.

Move an Object
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects that
you want to move.

3

Drag the edge of an object.

1

◆ To constrain the movement of

the object to multiples of 45
degrees or the current angle in
General preferences, hold
down the Shift key as you drag.
◆ If the path has a color fill,

appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.

Did You Know?

2

3

You can delete an object. Select the
object that you want to delete, and
then press Delete, or click the Edit
menu, and then click Clear.

See Also
See “Using Smart Guides” on page 50
for more information on setting Smart
Guide preferences and using Smart
Guides.
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Duplicating Objects

Duplicating objects can be a powerful way of creating geometrical artwork. You can duplicate one or more selected objects by dragging
them, using Arrow keys, copying to and pasting from the Clipboard, or
using the Offset Path command. When you copy objects to the
Clipboard, you can paste them on an artboard several different ways:
Paste, Paste in Front, Paste in Back, Paste in Place (New!), or Paste
on All Artboards (New!). The Offset Path command duplicates a path
(along with fill and stroke attributes) and places it on the artboard
based on the offset distance specified in the Offset Path dialog box.
The duplicate path is reshaped to fit around the original path.

Duplicate or Copy Objects
1

Select the Selection tool on the
Tools panel.

1

◆ If the object is in a group,

select the Direct Selection tool
on the Tools panel.
2

Use any of the following methods:
◆ Same Document. Hold down Alt

(Win) or Option (Mac), and then
drag the edge or fill of the
object.
◆ Different Documents. Open the

documents side by side, and
then drag the edge or fill of the
object from one document to
another.
◆ Copy/Paste from Clipboard.

Select the object, click the Edit
menu, and then click Copy.
Click in the target document or
artboard, click the Edit menu,
and then click Paste, Paste in
Front, Paste in Back, Paste in
Place (New!), or Paste on All
Artboards (New!).
◆ Keyboard. Select the object,

press Control (Win) or A
(Mac), and then use an Arrow
key to move the duplicated
object in the direction you
want. The duplicate object
moves away from the original
object based on the current
keyboard increment value in
General preferences.

92
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Duplicate Objects Using an
Offset
1

Select the Selection tool on the
Tools panel.

2

Select an object.

3

Click the Object menu, point to
Path, and then click Offset Path.

4

Enter the distance you want to
offset the duplicate path from the
original object.

5

Click the Joins list arrow, and then
select a bend style: Miter
(pointed), Round (circular), or
Bevel (square-cornered).

6

You can set a limit (1-500) to
determine when a mitered corner
changes into a beveled corner. A
low number creates a more
beveled corner, while a high
number creates a sharper corner.

7

1

2

4

7

Click OK.

6

5

Results
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Aligning and
Distributing Objects

In addition to using grids and guides to align objects to a specific point,
you can align a group of objects to each other. The Align panel buttons
make it easy to align two or more objects relative to each other or to
the page. To evenly align several objects to each other across the document, either horizontally or vertically, select them and then choose a
distribution option. Before you select an align command, specify how
you want Illustrator to align the objects. You can align the objects in
relation to the document or to the selected objects. If you want to align
all the objects to another object, you can select and use a key object,
before you select an alignment option.

Align or Distribute Objects
1

Select the Selection tool on the
Tools panel.

2

Select two or more objects to align
them or select three or more
objects to distribute them.

3

Select the Align panel or click
Align on the Control panel.

4

Click the Options menu, and then
click Use Preview Bounds. A
checked option uses the object’s
stroke weight and any applied
effects when aligning or
distributing.

5

If you want to align objects along
the edges of the artboard, click the
Align To menu on the Align or
Control panel, and then click Align
to Artboard. Objects are moved on
the artboard based on the
alignment or distribution command
to the closest edge (top and
bottom, or left and right).

6

7

94

If you want to align objects to a
key object, click an object to make
it the key object (a thick blue
outline appears and the Align To
Key Object option is selected in
the Align and Control panel).
Use the alignment and distribution
buttons on the Align or Control
panel.
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Transforming Objects

Transform an Object with the
Bounding Box
1

Click the View menu, and then
click Show Bounding Box to
display it.

2

Select the Selection tool on the
Tools panel.

3

Select one or more objects to
transform.

4

Use any of the following methods:

The easiest way to transform an object is to use the bounding box. With
the bounding box, you can quickly scale (resize), reflect (mirror), and
rotate an object. However, you cannot copy an object or move the reference point. As you drag to transform an object, you can use keyboard
keys to alter the results of a transformation. Experiment with the different options to create some new results.

2

3

◆ Scale. Drag a corner handle to

scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.

Scale

◆ Reflect. Drag a side handle all

the way across the object to
the other side.
◆ Rotate. Point slightly outside a

corner handle (pointer changes
to a double arrow), and then
drag in a circular motion.

Rotate

To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.
5

To transform an object using exact
values or percentages, select the
Transform panel.
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Using the Free
Transform Tool

The Free Transform tool allows you to rotate, scale (resize), reflect (mirror image), or shear (slant) an object. In addition, you can apply perspective and distortion to an object. However, you cannot copy an
object or move the reference point. As you drag to transform an object,
you can use keyboard keys to alter the results of a transformation. To
help you align the results the way you want, you can use Smart Guides
to make it easier.

Transform an Object with the
Free Transform Tool
1

Select the Free Transform tool on
the Tools panel.

2

Select one or more objects to
transform.

3

2

1

Use any of the following methods:
◆ Scale. Drag a corner handle to

scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.
◆ Reflect. Drag a side handle all

the way across the object to
the other side.
◆ Rotate. Point slightly outside a

corner handle (pointer changes
to a double arrow), and then
drag in a circular motion. To
rotate in 45 degree increments,
Shift-drag.
To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.
◆ Shear. Drag a side handle and

then hold down Ctrl (Win) or
A (Mac) as you continue to
drag. To constrain the
movement, also press Shift. To
shear from the center, also
press Alt (Win) or Option (Mac).
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Chapter 3

Shear results
Shear

C03ILCS5.qxp

3/18/2010

8:23 PM

Page 97

◆ Perspective. Drag a side

handle and then hold down
Ctrl+Alt+Shift (Win) or
A+Option+Shift (Mac) as you
continue to drag.

Perspective
results

◆ Distort. Drag a corner handle

and then hold down Ctrl (Win)
or A (Mac) as you continue to
drag.
4

Perspective

To use Smart Guides as you
transform an object:
◆ Select the Transform Tools

check box in Smart Guides
preferences.
◆ Click the View menu, and then

4

click Smart Guides to display
them.
◆ As you drag to transform an

object, smart guides appear in
your document, which you can
use to align the transformed
object.
5

To transform an object using exact
values or percentages, select the
Transform panel.
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Rotating and Scaling
Objects

After you create an object, you can change its orientation by rotating it
or change its size by scaling it. For a freeform rotation, when you want
to rotate the object in other than 90 or 180 degree increments, you can
use the Rotate tool. To resize an object, either smaller or larger, you can
use the Scale tool. With either tool, you can transform the object from
its center or the reference point. To rotate or scale an object using
exact values or percentages, use the Transform panel, which is available on the Control panel or Window menu.

Rotate or Scale an Object
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects to
transform.

3

Select the Rotate or Scale tool on
the Tools panel.

4

To move the reference point, click
a new point.

5

Use the appropriate method:

1

3
2

◆ Rotate. Drag in a circular

motion. To rotate in 45 degree
increments, Shift-drag.
◆ Scale. Drag away from or

toward the object. Shift-drag to
scale proportionally; hold down
Alt (Win) or Option (Mac), and
then drag to scale from the
center. Also hold down Shift to
scale from the center
proportionally.
◆ Scale and Flip. Drag across the

entire object.
◆ Scale and Copy. Hold down

Alt+Shift (Win) or Option+Shift
(Mac), and then drag.
6
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To rotate or scale an object using
exact values or percentages,
select the Transform panel.
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Reflecting and
Shearing Objects

The Reflect and Shear tools on the Tools panel allow you to be creative
as you transform an object. The Reflect tool creates a mirror image of
an object, while the Shear tool creates a slanted image of an object. To
reflect or shear an object using exact values or percentages, open the
Transform panel, which is available on the Control panel or Window
menu.

Reflect or Shear an Object
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects to
transform.

3

Select the Reflect or Shear tool on
the Tools panel.

4

To move the reference point, click
a new point.

5

Use the appropriate method:

1

3
2

◆ Reflect. Click to establish a

reference point, and then click
again to establish the axis of
reflection.
◆ Shear. Drag away from the

object.
6

To reflect or shear an object using
exact values or percentages,
select the Transform panel.

4

5

Reflect
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Applying Multiple
Transformations

The Transform Each command allows you to transform multiple objects
relative to their individual reference points instead of a single reference
point. With the Transform Each command, you can scale or move
objects horizontally or vertically, rotate objects by a specific angle, and
create a mirror reflection of the objects. If you want to create a unique
effect, you can also have Illustrator apply random transformations. You
can also use the Transform Effect command to create similar effects,
which you can modify.

Use the Transform Each
Command
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects to
transform.

3

Click the Object menu, point to
Transform, and then click
Transform Each.

4

Select the Preview check box to
view your changes on the selected
object.

5

Do any of the following:

2

Transformation

6

◆ Scale Horizontal or Vertical.

Drag the slider or enter a
percentage to scale objects
from their reference point.

4

◆ Move Horizontal or Vertical.

Drag the slider or enter a
percentage to move objects left
or right and up or down.
◆ Rotate Angle. Enter a rotate

angle or drag the dial.
◆ Reflect X or Y. Select to create

a mirror reflection of the
objects.
◆ Reference Point. Click a square

to change the reference point.
◆ Random. Select to apply

random transformations using
the values in the dialog box.
6
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Click OK or Copy (creates a copy
and applies the transformation).
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Use the Transform Effect
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects to
transform.

3

Click the Effect menu, point to
Distort & Transform, and then click
Transform.

4

Select the Preview check box to
view your changes on the selected
object.

5

Do any of the following:

2
Transformation
effect

6

◆ Scale Horizontal or Vertical.

Drag the slider or enter a
percentage to scale objects
from their reference point.
◆ Move Horizontal or Vertical.

Drag the slider or enter a
percentage to move objects left
or right and up or down.
◆ Rotate Angle. Enter a rotate

4

5

angle or drag the dial.
◆ Copies. Enter the number of

copies you want.
◆ Reflect X or Y. Select to create

a mirror reflection of the
objects.
◆ Reference Point. Click a square

to change the reference point.
◆ Random. Select to apply

random transformations using
the values in the dialog box.
6

Click OK.

7

To edit the transformation, select
the object, and then click
Transform on the Appearance
panel.

For Your Information
Repeating a Transformation
The Transform Again command allows you to quickly repeat the last
transformation with the last-used values on a selected object. To use
the command, transform and select an object or group, click the
Object menu, point to Transform, and then click Transform Again or
press Ctrl+D (Win) or A+D (Mac).
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Reshaping Objects
with Envelopes

Envelopes are objects you can use to reshape other objects, except
graphs, guides, or linked objects. You can use one of the built-in
envelopes or create your own out of an existing object. The built-in
envelopes use warp shapes or a mesh grid as the object. After you
apply an envelope, you can edit the original object or the envelope
(anchor points), separately, using the Selection and Mesh tools on the
Tools panel.

Distort Objects with an Envelope
1

Select the Selection tool on the
Tools panel.

2

Select one or more objects to
reshape.

3

Click the Object menu, point to
Envelope Distort, and then click
one of the following:

2

◆ Make With Warp. Uses a

preset warp shape.

5

◆ Make with Mesh. Uses a

rectangle grid.
◆ Make With Top Object. Uses an

object as the shape of the
envelope. The object needs to
be at the top of the stacking
order.
4

Specify the options you want for
the envelope type; select the
Preview check box to view your
changes on the selected object.

5

Click OK.

6

Do any of the following:
◆ Reshape. Select the Selection

or Mesh tool, and then drag
any anchor points.
◆ Delete Anchor Points. For a

mesh grid, select the Selection
or Mesh tool, select an anchor
point, and then press Delete.
◆ Add Anchor Points. For mesh

grid, select the Mesh tool, and
then click on the grid.
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Creating an Interactive
Document
Introduction
In the past, desktop publishing was exclusively considered a
print-based medium. However, with the introduction and
popularity of the PDF (Portable Document Format) file format
and the Adobe Reader as well as the SWF (ShockWave Flash)
file format and the Adobe Flash Player, interactive documents
are more popular than ever. Instead of creating a document
just for printing, you can now create an interactive document
with hyperlinks, bookmarks, and buttons for presentations.
You can even add animation using motion presets, page transitions, such as a wipe or dissolve, when you turn a page and
insert sounds and videos into an InDesign document in addition to graphics.
With the Hyperlinks panel, you can create hyperlinks that
navigate to external URLs, link to files with supplemental
information, launch an e-mail client, or jump to a page or
section of a page within the same or even a different document. You can also verify your hyperlinks directly in InDesign
with no need to export the document to a PDF or Flash (SWF)
file for testing.
The Buttons panel is a centralized place to work with
interactive buttons in InDesign. The Buttons panel makes it
easy to create interactive buttons that perform actions when
the document is exported to Flash (SWF file) or Acrobat
(PDF). You can create a custom button from a selected object
in an InDesign document or select a button from the built-in
Samples button library. When you create an interactive button, you can add events and actions to enable navigation
within a document, launch a movie, play a sound, or open a
Web page.

What You’ll Do
Define Hyperlink Destinations
Create Hyperlinks
Convert and Stylize Hyperlinks
Use the Hyperlinks Panel
Create Cross-References
Create Bookmarks
Add Media
Set Media Options

13
Add Animation with Motion Presets
Work with Animations

Change Animation Order
Add Page Transitions

Use the Buttons Panel
Create Buttons

Work with Events and Actions
Work with Button States
Set Button Tab Order

When you’re finished with your interactive document, you
can use the Preview panel to view animation and interactivity
for the current selection, current spread, or the entire document.

Create Multi-State Objects
Use the Preview Panel
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Defining Hyperlink
Destinations

A hyperlink is a text or graphic object that is linked to other parts of the
document, other documents, or Web pages. A hyperlink consists of a
source and a destination. The source is the text or graphic object that
you click to jump to the hyperlink location while the destination is the
place that InDesign sends you to. The destination can be in the same
document, another document, an e-mail message, or a Web page on
the Internet. You need to define a destination before you can define the
source.

Create a Hyperlink Destination
1

Select the Hyperlinks panel.

1

◆ Click the Window menu, point

2

to Interactive, and then click
Hyperlinks.
2

Click the Options menu, and then
click New Hyperlink Destination.

3

Click the Type list arrow, and then
select a hyperlink type:
◆ Page. Creates a link to a page

in the same document.
◆ Text Anchor. Creates a link to a

3

5

selected area of text.
◆ URL. Creates a link to a Web

page on the Internet.
4

Specify the options related to the
hyperlink type; options vary
depending on the type.

4

◆ For a Page. Specify a page

name, page number, and zoom
setting.
◆ For a Text Anchor. Specify a

name for the anchor.
◆ For an URL. Specify a name

and address for the URL
(Uniform Resource Locator).
5

346

Click OK.
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Edit or Delete a Hyperlink
Destination
1

1

Select the Hyperlinks panel.
2

◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
2

Click the Options menu, and then
click Hyperlink Destination
Options.

3

Click the Destination list arrow,
and then select a destination.

4

Click Edit or Delete.

5

If editing, make the changes you
want for the destination.

6

Click OK.

3

4

6

5
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Creating Hyperlinks

Before you can create a hyperlink, you need to define a hyperlink destination. After you create one or more hyperlink destinations, you can
create a hyperlink source, which is a text or graphic object that you
click to jump to a hyperlink destination. You can link a hyperlink to several different destination types, including URL, File, Email, Page, Text
Anchor, and Shared Destination. If you need a quick hyperlink to an
URL, you can create one with the New Hyperlink From URL command.

Create a Hyperlink
1

Select the text or graphic you
want to use as the hyperlink.

2

Select the Hyperlinks panel.
◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
3

Click the Options menu, and then
click New Hyperlink.

4

Click the Link To list arrow, and
then select an option:

1

◆ URL. Creates a link to a web

page on the Internet.
◆ File. Creates a link to a

document.
◆ Email. Creates an e-mail

message link, which opens
your default e-mail program.
◆ Page. Creates a link to a page

in the same document.
◆ Text Anchor. Creates a link to a

selected area of text.
◆ Shared Destination. Creates a

link to the same destination
from multiple sources.
5

Specify the options related to the
hyperlink type; options vary
depending on the type.
◆ For an URL. Specify a name

and address for the URL
(Uniform Resource Locator).
◆ For a File. Use the Browse

button to select a file to link.
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◆ For an Email. Specify an e-mail

4

address and message subject
line.
◆ For a Page. Specify a page

7

name, page number, and zoom
setting.
◆ For a Text Anchor. Specify a

5

name for the anchor.
◆ For a Shared Destination.

Specify a document name, and
hyperlink destination.
6

Specify a character style for the
text and appearance options for
the hyperlink.

7

Click OK.

6

Create a Hyperlink From an URL
1

Select the text that you want to
use to create a URL.

2

Select the Hyperlinks panel.

1

◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
3

2

Click the Options menu, and then
click New Hyperlink From URL.

3

Hyperlink from URL
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Converting and
Stylizing Hyperlinks

Convert and Stylize URLs to
Hyperlinks
1

If you have one or more URLs in your document, you can use the
Convert URLs to Hyperlink command (New!) to search the current
selection, story, or document for URL strings and convert them to
hyperlinks. The Convert URLs to Hyperlinks dialog box works like the
Find/Change dialog box. You can find URLs and convert one URL at a
time or convert them all at once. In addition to converting URLs to
hyperlinks, you can also apply a character style to create a consistent
look. However, if you don’t want them all the same, you can change the
style and appearance of individual hyperlinks.

1

Select the Hyperlinks panel.
2

◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
2

Click the Options menu, and then
click Convert URLs to Hyperlinks.

3

Click the Search list arrow, and
then select the scope option you
want: Document, Story, or
Selection.

4

To apply a character style to the
converted hyperlinks, select the
Apply to Hyperlink check box,
click the Character Style list
arrow, and then select a character
style.

5

3

Use the following buttons to find
or convert the URL strings:

4

◆ Find. Starts the search for the

next URL string.
◆ Convert. Converts the selected

URL string to a hyperlink.
◆ Convert All. Changes all find

URL strings to hyperlinks.
6

If the Finished Finding URLs alert
dialog box appears, click OK.

7

When you’re finished, click Done.
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Change the Appearance of a
Hyperlink
1

7

Select the Hyperlinks panel.
◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
2

Select the hyperlink you want to
edit.

3

Click the Options menu, and then
click Hyperlink Options.

5

◆ You can also double-click a

6

hyperlink in the Hyperlinks
panel.
4

Double-click the hyperlink in the
Hyperlinks panel.

5

For text, select the Style check
box, and then select a character
style.

6

Make the changes you want for
the hyperlink appearance.
◆ Type. Specify a visibility setting

for the hyperlink.
◆ Highlight. Specify a highlight

setting for the hotspot.
◆ Color. Specify a color for the

hyperlink.
◆ Width. Specify a thickness for

the visible rectangle type.
◆ Style. Specify a line style for

the visible rectangle type.
7

Click OK.
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Using the Hyperlinks
Panel

The Hyperlinks panel is a centralized place to work with hyperlinks and
cross references in InDesign. The redesigned Hyperlinks panel makes
it easy to create hyperlinks that navigate to external URLs, link to files
with supplemental information, launch an e-mail client, or jump to a
page or section of a page within the same or even a different document. You can also verify your hyperlinks directly in InDesign with no
need to export the document to a PDF or Flash (SWF file) for testing.
You can use buttons on the bottom of the panel to go to the hyperlink
source or destination, create a new hyperlink, or delete hyperlinks.

Use the Hyperlinks Panel
1

Select the Hyperlinks panel.

1

◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
2

Options menu

Use any of the following buttons
or commands to perform an
operation:
◆ Go to the Hyperlink Source.

Select the hyperlink, and then
click the Go to Source button.
◆ Go to the Hyperlink

Destination. Select the
hyperlink, and then click the
Go to Destination button.
◆ Create a New Hyperlink.

Create a destination, and then
click the Create New Hyperlink
button.
◆ Delete a Hyperlink. Select the

hyperlink, click the Delete
Selected Hyperlinks button,
and then click Yes.
◆ Reset a Hyperlink. Select the

hyperlink, click the Options
menu, and then click Reset
Hyperlink.
◆ Update a Hyperlink. Select the

hyperlink, click the Options
menu, and then click Update
Hyperlink.
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Edit a Hyperlink
1

Select the Hyperlinks panel.

1

◆ Click the Window menu, point

3

to Interactive, and then click
Hyperlinks.
2

Select the hyperlink you want to
edit.

3

Click the Options menu, and then
click Hyperlink Options.

2

◆ You can also double-click a

hyperlink in the Hyperlinks
panel.
4

Click the Link To list arrow, and
then select an option:

4

◆ URL. Creates a link to a web

page on the Internet.

6

◆ File. Creates a link to a

document.
5

◆ Email. Creates an e-mail

message link, which opens
your default e-mail program.
◆ Page. Creates a link to a page

in the same document.
◆ Text Anchor. Creates a link to a

selected area of text.
◆ Shared Destination. Creates a

link to the same destination
from multiple sources.
5

Specify the options related to the
hyperlink type; options vary
depending on the Link To type.

6

Click OK.

See Also
See “Creating Hyperlinks” on page
348-349 for more information on setting
options for editing a hyperlink.
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Creating CrossReferences

A cross-reference refers a reader from one section of a document to
another. For example, For more information, see “Using the Hyperlinks
Panel” on page 352. The text being referred to is the destination text,
while the text generated from the destination is the source cross-reference, which is editable. The Hyperlinks panel is a centralized place to
create and work with hyperlinks and cross references in InDesign. You
can use buttons on the bottom of the panel to go to the cross-reference
source or destination, create a new cross-reference, or delete crossreferences. When you create or edit a cross-reference, you can select
format and appearance settings for the reference.

Create a Cross-Reference
1

Click to place the insertion point
where you want the crossreference.

2

Select the Hyperlinks panel.

2

◆ Click the Window menu, point

to Type & Tables, and then click
Cross-References.
3

Click the New Cross-Reference
button on the panel.

4

Click the Link To list arrow, and
then select a link type.

5

Click the Document list arrow, and
then select a document location.

6

Select a paragraph in the
document or a hyperlink
destination for the text anchor.

7

Click the Format list arrow, and
then select a cross-reference
format.

8

3

4

5
6

Make the changes you want for
the cross-reference appearance.

7

◆ Type. Specify a visibility setting.
◆ Highlight. Specify a highlight

setting for the hotspot.
8

◆ Color. Specify a color.
◆ Width. Specify a thickness for

the visible rectangle type.
◆ Style. Specify a line style for

the visible rectangle type.
9

354

Click OK.
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Work with Cross-References
1

Select the Hyperlinks panel.

Options
menu

1

◆ Click the Window menu, point

to Interactive, and then click
Hyperlinks.
2

Use any of the following buttons
or commands to perform an
operation:

Out of date

◆ Go to the Cross-Reference

Source. Select the reference,
and then click the Go to Source
button.

Missing link

2

◆ Go to the Cross-Reference

Destination. Select the
reference, and then click the
Go to Destination button.
◆ Create a New Cross-

Reference. Select the crossreference text, and then click
the Create New CrossReference button.
◆ Edit a Cross-Reference.

Crossreference

Double-click the crossreference in the panel.
◆ Delete a New Cross-

Reference. Select the
reference, click the Delete
Selected Cross-Reference
button, and then click Yes.
◆ Reset a New Cross-Reference.

Select the reference, click the
Options menu, and then click
Reset Cross-Reference.
◆ Update a Cross-Reference.

Select the reference, click the
Options menu, and then click
Update Cross-Reference.
◆ Relink a Cross-Reference.

Select the reference, click the
Options menu, click Relink
Cross-Reference, select the
reference, and then click OK.

For Your Information
Creating or Editing Cross-Reference Formats
When you create or edit a cross-reference, you can also select a
format, such as Page Number Only or Full Paragraph & Page
Number. You can create new formats or edit the existing formats to
customize your own. In the Cross-Reference dialog box, click the
Create or Edit Cross-Reference Formats button, enter a name, click
the different reference formats and add your own text to create
your own definition. When you’re done, click OK. You can also click
the Options menu, and then click Define Cross-Reference Formats
to make changes.
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Creating Bookmarks

Bookmarks provide another way to navigate through a document. You
can create bookmarks that will point to a place in a text frame, any
selected text, a frame, or a page. You can create and work with bookmarks in the Bookmarks panel. When you create a PDF of your document, readers can use the bookmarks to navigate from one location to
another by using the Bookmarks panel.

Create and Rename a Bookmark
1

Do one of the following to select a
bookmark location:
◆ Insertion Point. Click to place

1

the insertion point where you
want the bookmark.
◆ Text. Select any text to specify

a location.
◆ Frame. Select a text or graphic

frame to specify a location.
◆ Page. Double-click a page in

the Pages panel to specify a
page location.
2

Select the Bookmarks panel.
◆ Click the Window menu, point

2

to Interactive, and then click
Bookmarks.
3

Click the New Bookmark button
on the panel.

4

Click the bookmark to select it.

5

Click the bookmark again to make
the name editable.

4

◆ You can also click the Options

menu, click Rename Bookmark,
enter a name, and then click
OK.
6

356

Type a name for the bookmark,
and then press Enter (Win) or
Return (Mac).
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Use the Bookmarks Panel
1

Select the Bookmarks panel.

1

◆ Click the Window menu, point

to Interactive, and then click
Bookmarks.
2

Use any of the following buttons
or commands to perform an
operation:

Options
menu

◆ Create a New Bookmark.

Select a location, and then
click the Create New
Bookmark button.
◆ Delete a Bookmark. Select the

2

bookmark, click the Delete
Selected Bookmarks button,
and then click OK.
◆ Rename a Bookmark. Select

the bookmark, click the Options
menu, click Rename Bookmark,
type a name, and then click OK.
◆ Go to a Selected Bookmark.

Select the bookmark, click the
Options menu, and then click
Go to Selected Bookmark.
◆ Sort Bookmarks. Click the

Options menu, and then click
Sort Bookmarks.
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Adding Media

With the Place command or Media panel, you can import the sound or
video clips that you want to play in your interactive document. You can
import video files in Flash Video format (FLV and F4Vm), H.264-encoded
files (such as MP4), and SWF (ShockWave Flash) files (New!). You can
import audio files in MP3 format. Legacy media files, such as QuickTime
(MOV), AVI, WMV, and MPEG, are still supported. However, if you want
to take advantage of the rich media support in Acrobat 9, Adobe Reader
9, and Adobe Flash Player 10 or later, you need to convert and relink
your legacy media to FLV, F4V, SWF, MP4, or MP3 using Adobe Media
Encoder. After you import sound and video files, you can preview them
in the Preview panel (New!) in InDesign or export them to Adobe PDF
or SWF, or XML. You can export legacy media files to PDF files, but not
to SWF or FLA files. If you have video on a Web server, you can place
the video from a URL (New!). If you’re not sure what to play, you can
create an empty frame (with diagonal lines) and then import the clip
later. When you import a media file, a poster image appears, which you
can change or remove later.

Insert a Media File
1

Click the File menu, and then click
Place, or select the Media panel,
and then click the Place Video or
Audio File button on the panel
(New!).
◆ Place a Video from a URL.

Select the Media panel, click
the Place Video From URL
button on the panel, type the
URL, and then click OK (New!).
2

Navigate to the location with the
file you want to import.

3

Select the sound or video file you
want to place.

4

Click Open.
The imported sound or movie is
placed in a loaded preview cursor.

5

358

Click or drag a rectangle frame
with the loaded cursor to place the
clip in a new sound or movie
frame, or click in an empty sound
or movie frame (designated by
diagonal lines) to place it in an
empty frame.
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Convert and Relink Legacy
Media Files Using Adobe
Media Encoder
1

3

4
5

Start Adobe Media Encoder from
the All Programs menu (Win) or
the Applications folder (Mac).

2

IMPORTANT Adobe Media
Encoder doesn’t convert audio
files to MP3. You need to use
another program, such as iTunes.
2

Click Add, select the media files
you want to convert, and then
click Open.

3

Select each media file, click the
Format list arrow next to the file
name, and then select a
conversion file format.

4

Click Start Queue.
The media files are converted to
the new media format and placed
in the same folder as the original
media file.

5

When you’re done, click the File
menu, and then click Exit, or click
the Close button.

6

To relink the media files, select the
Links panel, Alt (Win) or Option
(Mac) click the Relink button on
the panel, select the replacement
media file for each one (or click
Skip if not available), and then
click Open.

Legacy MOV video to relink

6

Did You Know?
You can preserve transformation when
you update or reestablish a link. Click
the Edit (Win) or InDesign (Mac) menu,
point to Preferences, click File
Handling, select the Preserve Image
Dimensions When Relinking check box,
and then click OK.
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Setting Media Options

After you import media files into a document, you can use the Media
panel (New!) to preview media, set playback and other properties. You
can preview FLV, F4V, SWF, MP4, and MP3 files directly in InDesign; all
other legacy media cannot be viewed in the Media panel. You can
select the playback controls you want, and select the placeholder
poster image for FLV, F4V, and MP4 files. A placeholder poster image is
the still image that appears for the media in the frame, which you can
change or remove later. In addition, you can create navigation points,
which are time-code markers, that you can use with button actions to
play a video starting from any of the navigation points (New!). You can
work with media frames like any other frame in InDesign.

Set Sound Options
1

Select the sound clip.

2

Select the Media panel.

Poster image

1

◆ Click the Window menu, point

to Interactive, and then click
Media.
3

Select any of the following check
boxes to enable the option:

2

◆ Play on Page Turn. Select to

play the sound when turned to
the page. If other objects are
set to play, the Timing panel
determines the order.
◆ Stop on Page Turn. Select to

stop playing an MP3 sound
when turned to a different
page.
◆ Loop. Select to play the MP3

sound repeatedly.
4

Click the Poster list arrow, and
then select a poster option:
◆ None. Removes poster image.
◆ Standard. Uses the file:

StandardSoundPoster.jpg.
◆ Choose Image. Use the Browse

button to select a bitmap
graphic (BMP).

360
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Set Video Options
1

Select the video clip.

2

Select the Media panel.

2

◆ Click the Window menu, point to

Interactive, and then click
Media.
3

Select any of the following check
boxes to enable the option:
Mute, Play/Pause, and Slider

◆ Play on Page Turn. Select to

play the video when turned to
the page. If other objects are set
to play, the Timing panel
determines the order.

3
4
Use Current Frame button

◆ Loop (SWF export only). Select

5

to play the video repeatedly. For
SWF Flash video, it only works
in exported files.
4

6

Click the Poster list arrow, and then
select a poster option:
◆ None. Removes poster image.
◆ Standard. Uses the file:

StandardMoviePoster.jpg.
◆ From Current Frame. Uses the

current frame displayed in the
Media panel. Use the slider to
change it, and then click the
Use Current Frame button.
◆ Choose Image. Use the Browse

button to select a bitmap
graphic (BMP).
5

Click the Controller list arrow,
select a playback control skin.
◆ Show Controller on Rollover.

Select to show the controller
when you point to the media.
6

To create a navigation point, drag
the slider to a frame, and then click
the Add Nav Point button, type a
name, and then press Enter (Win)
or Return (Mac). To remove a
navigation point, select the point
name in the list, and then click the
Delete Nav Point button.

Added video
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Adding Animation
with Motion Presets

Apply an Animation Motion
Preset and Set Options
1

Select the object you want to
animate.

2

Select the Animation panel.

In an InDesign document, you can add animation to objects for use in
exported SWF files, not in an Interactive PDF. To add animation to a
PDF, export a selection as a SWF and place it in an InDesign document,
and then export it as a PDF. With the Animation panel (New!), you can
animate an object quickly using motion presets, which are pre-defined
animations that come along with InDesign. The motion presets are the
same ones used in Adobe Flash Professional CS5. You can import any
custom presets from XML created in Flash or save your own in
InDesign. After you apply a motion preset, you can modify animation
settings (New!), such as speed, duration, and when the animation
plays. If you no longer want to use an animation, you can remove it.

2

◆ Click the Window menu, point

to Interactive, and then click
Animation.
3

Type a descriptive name for the
animation. The name is also used
when you set up an action to play
the animation.

4

Click the Preset list arrow, and
then select a motion preset.

5

Click the Event(s) list arrow, and
then select an event to play the
animated object in the SWF file.
◆ On Page Load. Plays when the

page is loaded (selected by
default).
◆ On Page Click. Plays when the

page is clicked.
◆ On Click (Self). Plays when the

object is clicked.
◆ On Roll Over (Self). Plays when

the object is pointed to. To
reverse the action when you
point off the object, select the
Reverse On Roll Off check box.
◆ On Button Event. Plays when a

button action takes place.
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6

To create a button trigger, click the
Create Button Trigger button, click
an object to convert it to a button,
and then set options in the Buttons
panel.

7

Specify a duration for the
animation and the number of time
the animation plays, or select the
Loop check box to repeatedly play
the animation.

8

9

6
7

Click the Speed list arrow, and
then select an option: From Preset
for the default, None for a steady
rate, Ease In to start slow and
speeds up, or Ease Out to start fast
and slows down.

8

9

To use advanced options, click the
Properties arrow, and then do any
of the following:
◆ Animate. Select From Current

Appearance or To Current
Appearance to use the object’s
current properties as the
starting or ending point. Select
To Current Location to use the
object’s properties as the
starting and ending point.

10

◆ Rotate. Specify a rotation angle

the object completes.
◆ Origin. Uses the proxy to

specify the origin point of the
motion path.
◆ Scale. Specify a percentage to

increase or decrease the size.
◆ Opacity. Select None (remains

solid), Fade In (goes to visible),
or Fade Out (goes to invisible).
◆ Visibility. Select the Hide Until

Animated or Hide After
Animating check boxes to
make an object invisible before
or after playback.
10 To remove an animation from an

object, select the object, and then
click the Delete button on the
Animation panel.
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Working with
Animations

Manage Animation Motion
Presets
1

1

Select the Animation panel.
◆ Click the Window menu, point

to Interactive, and then click
Animation.
2

With the Animation panel (New!), you can import any custom motion
presets from XML created in Flash or InDesign, or save your own in
InDesign. If you want to share your motion presets with other InDesign
users, you can save them as an XML file, which they can in turn import.
After you import, save, or duplicate motion presets, you can delete the
ones you don’t want. After you apply a motion preset to an object, you
can change the motion path with the Direct Selection tool or Pen tool
just like any other path in InDesign.

2

Perform any of the following
management options:
◆ Save Motion Presets. Specify

the settings you want to save,
click the Options menu, click
Save, type a name, and then
click OK.
◆ Delete Motion Presets. Click

the Options menu, click
Manage Presets, select a
preset, and then click Delete.
◆ Duplicate Motion Presets.

Click the Options menu, click
Manage Presets, select a
preset, and then click
Duplicate.
◆ Save Motion Presets as XML.

Click the Options menu, click
Manage Presets, select a
preset, click Save As, type a
name, specify a location, and
then click Save.
◆ Import Motion Presets as XML.

Click the Options menu, click
Manage Presets, click Load,
and then double-click the XML
file you want.

364

Chapter 13

Manage
Presets
dialog box

C13IDCS5.qxp

3/18/2010

10:06 AM

Page 365

Edit a Motion Path
1

Select the Direct Selection tool on
the Tools panel.

2

Click a blank area to deselect all
points.

3

To select and move multiple
anchor points and segments, hold
the Shift key, and then click the
anchor points or segments you
want, or drag a rectangle marquee
around the ones you want.

4

Drag an anchor point or drag the
middle of a segment.

1

4

◆ For a smaller move, click the

anchor point or segment, and
then press an arrow key.
◆ To constrain the movement of

anchor points or segments to
45 degrees, hold down Shift
while dragging.
5

Edited motion path

To reshape a curve segment, click
an anchor point or a curve
segment, and then drag a
direction point at the end of the
direction handle.

Did You Know?
You can convert selected objects to a
motion path. Select the object you
want to animate and the path you want
to use as the motion path (cannot
select more than two objects), select
the Animation panel, click the Convert
To Motion Path button on the panel,
and then change settings in the panel.
You can change the direction of the
motion path. Select the motion path,
click the Object menu, point to Paths,
and then click Reverse Path.
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Changing Animation
Order

With the Timing panel (New!), you can change the order of when
objects play an animation. Animated objects on the current spread
appear in the Timing panel based on the page event assigned to each
object animation, either On Page Load, On Page Click, or Unassigned.
You can change the animation order, delay time, event assignment, and
play animations together, separately, or linked.

Use the Timing Panel
1

Select the Timing panel.

1

◆ Click the Window menu, point to

Interactive, and then click
Timing, or click the Show
Timing Panel button on the
Animation panel.
2

Click the Events list arrow, and then
select an event type: On Page Load,
On Page Click, or Unassigned.

3

Perform any of the following:

2

◆ Animation Order. Drag elements

up or down the list. Items at the
top play first.
◆ Delay Animation. Select a

element, and then specify the
delay in seconds.
◆ Play Multiple Animations

3

Together. Select the elements,
click the Play Together button
on the panel to link them. To
unlink Play Together elements,
select them, and then click the
Play Separately button on the
panel.
◆ Play Linked Animations. Select

the linked elements, and then
specify the number of play times
or select the Loop check box.
◆ Remove Animation. Select a

element, click the Options menu,
and then click Remove Item.
◆ Reassign Animation. Select a

element, click the Options menu,
and then click Reassign to On
Page Load or Reassign to On
Page Click.
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Adding Page
Transitions

A page transition displays a visual effect, such as a wipe or dissolve,
when you turn the page in an interactive document. You can apply page
transitions directly in InDesign to individual pages or to all spreads at
once with a single click. See previews of available transition types in
the Page Transitions dialog box, and control the direction and speed of
your transitions for export to Flash (SWF file) or PDF. When you export
your document to a PDF, select the Interactive Elements option in the
Export PDF dialog box to include page transitions. You can view the
page transitions in Full Screen Mode in the PDF by pressing Ctrl+L
(Win) or A+L (Mac) in Adobe Acrobat or Reader; press Esc to exit
from Full Screen Mode.

Apply a Page Transition
1

Select the Pages panel, and then
select the spread to which you
want to apply a page transition.

2

Select the Page Transitions panel.

1

◆ Click the Window menu, point

to Interactive, and then click
Page Transitions.
3

Click the Transition list arrow, and
then select a transition.
◆ To select a page transition from

the Page Transitions dialog
box, click the Options menu,
click Choose, select a
transition, and then click OK.
2

4

Click the Direction list arrow, and
then select a transition direction.

5

Click the Speed list arrow, and
then select a transition speed.

6

To apply the current transition to
all spreads, click the Apply To All
Spreads button on the panel.

7

To clear all page transitions, do
either of the following:

3

◆ Click the Transition list arrow,

4

and then click None.
5

◆ Click the Options menu, and

then click Clear All.
6
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Using the Buttons
Panel

The Buttons panel is a centralized place to work with interactive buttons in InDesign. The Buttons panel makes it easy to create interactive
buttons that perform actions when the document is exported to Flash
(SWF file) or PDF. You can use buttons on the bottom of the panel to
convert an object to a button and to delete buttons. You can also use
the Options menu to view sample buttons, set options to show (make
visible) or hide buttons in PDFs, as well as set panel options.

Use the Buttons Panel
1

Select the Selection tool on the
tools panel, and then select a
button to view or change.

2

Select the Buttons panel.

2

◆ Click the Window menu, point

3

to Interactive, and then click
Buttons.
3

Click the Options menu, and then
select one of the following PDF
options (a check mark appears
next to the selected item):
◆ Sample Buttons. Opens the

Sample Buttons panel to
access and use pre-built
buttons.
◆ PDF Options. Opens the PDF

Options dialog box. Type a
description to provide
alternative text for visually
impaired users. To make the
button printable in the PDF,
select the Button is Printable
check box.
◆ Reset All Buttons to Normal

State. Resets all buttons back
to the normal state.
◆ Panel Options. Changes the

thumbnail size in the Buttons
panel.
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Change the Buttons Panel
Display
1

Select the Selection tool on the
tools panel, and then select a
button to view or change.

2

Select the Buttons panel.

2

◆ Click the Window menu, point

3

to Interactive, and then click
Buttons.
3

Click the Options menu, and then
click Panel Options.

4

Select a thumbnail size.

5

Click OK.

Did You Know?
You can delete a button. Select the
Buttons panel, select the button, and
then click the Delete button on the
panel.

5

4
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Creating Buttons

You can build interactive buttons to perform an action using the Buttons
panel. For example, you can create a button to navigate within a
dynamic document, launch a movie, play a sound, or open a Web page.
You can create a custom button from a selected object in an InDesign
document or select a button from the built-in Samples button library.
The sample buttons include effects, such as adding gradient feathers
and drop shadows. There are also assigned actions. For example, the
arrow buttons are assigned the Go To Next Page or Go To Previous
Page action.

Create a Button from a Sample
1

1

Select the Buttons panel.
◆ Click the Window menu, point

2

to Interactive, and then click
Buttons.
2

Click the Options menu, and then
click Sample Buttons.

6

The Sample Buttons panel
appears.
3

Drag a button from the Sample
Buttons panel to the document.

4

Click the Close button on the
Sample Buttons panel.

5

Select the button using the
Selection tool on the Tools panel.
◆ You can drag a resize handle to

change the size of the button,
and then move it to where you
want.
6

4

Enter a name and make changes
to the button settings in the
Buttons panel.

3
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Convert an Object to a Button
1

Create and select an object that
you want to convert to a button.

1

IMPORTANT You can convert
any object to a button except a
sound, movie, or poster.
2

Select the Buttons panel.
◆ Click the Window menu, point

2

to Interactive, and then click
Buttons.
3

Click the Convert Object to Button
button on the panel.

4

Type a name for the button.

5

Click the Event list arrow, and then
select an event type.
◆ The options include On

Release, On Click, On Roll Over,
On Roll Off, On Focus, and On
Blur.
6

◆ The options include Close, Exit,

Go To First Page, Go To URL,
Movie, Sound, and Open File,
among others.
7

3

Click the Add New Action button,
and then select an action to
perform for the button.
4

5

Specify the various options for the
selected action type (options
vary).

6

Did You Know?
You can convert a button to an object.
Select the button, select the Buttons
panel, click the Convert Button To An
Object button, and then click OK.

7
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Working with Events
and Actions

An event determines when to trigger an action that will execute a button operation. For example, the On Release event triggers an action
when the mouse button is released after a button click. An action is
associated with an event. You can assign an action type to a button to
perform an action. For example, the Go To URL action type opens a web
page in your default browser from the PDF document with the interactive button. You can create actions to navigate to anchor text or bookmarks, document pages and views, to launch a movie, play a sound, or
open a web page. You can work with events and actions for a selected
button in the Buttons panel.

Select Events for a Button
1

2

Select the Selection tool on the
tools panel, and then select a
button to change.

1

Select the Buttons panel.
◆ Click the Window menu, point

to Interactive, and then click
Buttons.
3

2

Click the Event list arrow, and then
select an event type.
◆ On Release. Event occurs

when the mouse button is
released after a click.
◆ On Click. Event occurs when

the mouse button is clicked.
◆ On Roll Over. Event occurs

when the mouse pointer enters
the button.
◆ On Roll Off. Event occurs when

the mouse pointer moves off
the button.
◆ On Focus (PDF). Event occurs

when the button gets the focus
using the Tab key.
◆ On Blur (PDF). Event occurs

when the focus moves to
another button or form field
using the Tab key or mouse
click.
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Add or Edit Actions for a Button
1

Select the Selection tool on the
tools panel, and then select a
button to change.

2

Select the Buttons panel.

2

3

◆ Click the Window menu, point

to Interactive, and then click
Buttons.
3

Click the Event list arrow, and then
select an event type.

4

Click the Add New Action button,
and then select an action to
perform for the button.

5

Specify the various options for the
selected action type (options
vary).

6

To enable or disable an action,
select or deselect the check box
next to the action name.

7

To delete an action, select the
action, click the Delete Selected
Action button, and then click OK.

8

To change an action order, drag
an action to a new position.

1

4

7
6

5
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Working with Button
States

A button consists of a group of individual objects. When you view a
button, an object appears. When you point to or click on a button,
another object appears. Each object represents a button state. Each
button can have up to three states: Normal, Rollover, and Click. The
button is in Normal state when you don’t point to or click on the button,
Rollover occurs when you point to the button, and Click occurs when
you click the button. You can work with button states for a selected
button in the Buttons panel. When you activate a state in the Buttons
panel, the Normal state (default) is copied to it. After it’s copied, you
can change the appearance of the button using InDesign color, text,
and image tools.

Work with Button States
1

2

Use the Selection tool to select a
button or use the Direct Selection
tool to select a button as an
individual object (state).

1

Select the Buttons panel.
◆ Click the Window menu, point

to Interactive, and then click
Buttons.
3

Click the [Rollover] or [Click] state
to activate it.

4

Use any of the following to change
the state appearance in the layout
view.

2

◆ Change Color. Use the Color

and Swatches panel to select a
color.
◆ Add Text. Select the Type tool,

click a button, and then type.
◆ Insert Graphic. Click the File

menu, click Place, and then
double-click a graphic file.
5

To disable/enable a state, click the
Eye icon next to the state. Disabled
states (no Eye icon) are not
exported to the SWF or PDF.

6

To delete a state, select the
[Rollover] or [Click] state, and then
click the Delete button on the
panel (you can't delete Normal).
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Setting Button Tab
Order

The tab order determines when a button receives focus as you press
the Tab key in a SWF or PDF document. When a button receives focus,
you can press Enter (Win) or Return (Mac) to execute the button. You
can also use the On Focus event to trigger an action when a button
gets the focus. In the Tab Order dialog box, you can change the tab
order for optimal use. The tab order includes buttons on hidden layers,
but not buttons on master pages.

Set the Button Tab Order
1

Select the Pages panel, and then
double-click the page containing
the buttons you want to set the tab
order for.

2

Click the Object menu, point to
Interactive, and then click Set Tab
Order.

1

◆ The tab order includes buttons

on hidden layers, but not
buttons on master pages.
3

Select the button you want to
move.

4

Click the Move Up or Move Down
buttons to adjust the order.

5

Click OK.

3

5

4
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Creating Multi-State
Objects

With the Object States panel (New!), you can create multiple versions
of an object, known as a state, on a page. An object with multiple
states is called a multi-state object. Each time you create a new state,
you create a new version of the selected object to the page. Only one
state is visible on the page at a time. For example, you can create a
slide show for use in a PDF or SWF, where each image is stacked and
aligned on top of each other as a multi-state object. When you print the
document or export it as a PDF, only the active state appears. After you
create a multi-state object, you can edit it in a variety of ways. You can
edit an object in a state, add to or duplicate objects in a state, or delete
a state and its contents. If you want to break apart a multi-state object,
you can convert it to independent objects.

Create a Multi-State Object
1

Select the objects you want to
convert into a multi-state object.

2

To stack the objects on top of each
other, click the Align Horizontal
Centers and Align Vertical Centers
buttons on the Control or Align
panel.

3

Select the Object States panel.

1

◆ Click the Window menu, point to

Interactive, and then click
Object States.
4

Click the Convert Selection To
Multi-State Object button on the
panel.
The objects appears as states in
the panel and a dashed frame
border appears around them in the
document.

5

Type a name for the multi-state
object.

6

Click the default state name, type
name, and then press Enter (Win)
or Return (Mac).

7

To select the multi-state object,
click the Multi-State button.

3

5

7

◆ To select a state, click the state

in the list.
6
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Edit a Multi-State Object
1

Select a multi-state object.

2

Select the Object States panel.
◆ Click the Window menu, point to

1

Interactive, and then click
Object States.
3

Perform any of the following:
◆ Edit a State. Select the state in

the panel, and then edit it in the
document.
◆ Add an Object to an Existing

State. Select the object and
multi-state object, and then click
the Add Objects To Visible State
button on the panel.
◆ Paste an Object to an Existing

2

3

State. Cut or copy the object to
the Clipboard, select the multistate object, select the state in
the panel, click the Options
menu, and then click Paste Into
State.
◆ Duplicate a State. Select the

state in the panel, click the
Options menu, and then click
New State.
◆ Delete a State and Remove

Contents. Select the state in the
panel, click the Options menu,
and then click Delete State.
◆ Convert a Multi-State Object to

Independent Objects. Select the
state in the panel, click the
Options menu, and then click
Release State To Object.
◆ Hide a Multi-State Object in an

Export Until Triggered. Click the
Options menu, and then click
Hide Until Triggered.
◆ Reset All Multi-State Objects to

the First State. Click the Options
menu, and then click Reset All
Multi-State Objects To First
State.
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Using the Preview
Panel

If you’re working on an interactive document, you can use the Preview
panel (New!) to view animation and interactivity for the current selection, current spread, or the entire document. If you want to test your
interactive document in your browser, you can open it from the Preview
panel. If the preview display is not exactly what you want, you can set
general and advanced options in the Preview Settings dialog box to
change it. Some of the options include size, background, interactivity
and media, page transitions, frame rate, and image handling resolution,
compression and quality.

Use the Preview Panel
1

Select the object or display the
spread or document (interactive)
you want to preview.

2

Select the Preview panel.

2

6

◆ Click the Window menu, point

to Interactive, and then click
Preview.
3

Click a preview mode button on
the panel: Set Preview Selection
Mode, Set Preview Spread Mode,
or Set Preview Document Mode.

4

To play the preview, click the Play
Preview button on the panel.
◆ To erase the preview, click the

Clear Preview button on the
panel.
5

To set preview settings, click the
Options menu, click Edit Preview
Settings, select the options you
want on the General and
Advanced tabs, and then click
Save Settings.

6

To test in your browser, click the
Options menu, and then click Test
in Browser.

4

3

5
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Viewing the HTML Behind
the Page
Introduction
In the world of the Internet, the graphics, text, animation, and
all the "stuff" that the visitor sees displayed in their browser
is the front end of a Web page, and the power behind the
page is the HTML code. The HTML code sits quietly behind
the scenes, letting the front end get all the credit; however,
without the code, the Internet would fall apart. It's the cosmic
glue that holds the whole thing together.
Designers, like myself, remember when there were no
graphical design interfaces (like Dreamweaver), and all Web
pages were designed code line, by tedious code line. I
remember working by candlelight into the wee hours of the
morning, until I thought my head was going to burst… okay,
so maybe I didn't use candles, but it was a lot of painstaking
work. Although Dreamweaver changed all of that with its
intuitive graphical design interface, the code is still there.
However, we're not the ones doing the coding, Dreamweaver
is… and isn't that nice?

What You’ll Do
Understand HTML
Use the Reference Panel
Use Code View
Use Live Code View
Set Code View Options
Enter HTML Code
Use Code Hints
Work with HTML Head Tags

14
Insert HTML Comments

Use the Coding Toolbar
Use Quick Tag Editor

Use the Tag Inspector and Chooser
Open Related Files

Navigate to Related Code

Set Site Specific Code Hints
Set Code Hint Preferences

Set Code Format Preferences

Set Code Rewriting Preferences
Set Code Color Preferences
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Understanding HTML
HTML stands for the HyperText Markup
Language. HTML code is the major language
of the Internet's World Wide Web. Web sites
and Web pages are written in HTML code.
With HTML code and the World Wide Web,
you have the ability to bring together text,
pictures, sounds, and links... all in one place!
HTML code files are plain text files, so they
can be composed and edited on any type of
computer... Windows, Mac, UNIX, whatever.
HTML documents look a lot like word processing documents. You can have text that's
bold and italicized, larger and smaller, or it
can look typewritten. The HTML code might
look something like this:
You can have <b>bold</b> and <i>italicized</i>, <font size=+2>Larger</font> and <font
size=-2>Smaller</font>, or it could look <tt>typewritten</tt>.
Most HTML code is enclosed within braces
< >, and when you place the code between
the braces it's said to be a tag. An HTML tag
is code inserted in a document that specifies
how the document, or a portion of the document, should be formatted. For example, the
<b> tag is saying to start bold text, and the
</b> tag is saying to stop bold text. The tag
with the slash (/) is known as the closing tag.
Many opening tags require a following closing tag, but not all do. Tags make up the
entire structure of an HTML document.
HTML files are just normal text files; they
usually have the extension of .htm, .html, or
.shtml. HTML documents have two parts, the
head and the body. The body is the larger part
of the document, as the body of a letter you
would write to a friend. The head of the document contains the document's title and similar information, and the body contains most
everything else.
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Common Tags
Symbol

Defines

<html>

Start of the HTML document

<head>

The document heading

<body>

The body of the document

<title>

The document title

<div>

A section in a document

<span>

A section in a document

<h1>

Text heading

<p>

A paragraph

<style>

Format of text

<img>

An image placeholder

<a>

A hyperlink

<iframe>

An inline frame

<!-- comment --> A comment

Here’s an example of a basic HTML document:
<html>
<head><title>Title goes
here</title></head><body>Body goes here</body>
</html>
You may find it easier to read if you add
extra blank lines such as follows...
<html>
<head>
<title>Title goes here</title>
</head>
<body>
Body goes here
</body>
</html>
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Extra spaces and line breaks (blank lines) are
ignored when the HTML is interpreted (displayed) by a Web browser, such as Microsoft
Explorer or Apple Safari... so add them if you
wish.
When working with HTML code, it's all
about the tags. The HTML tags instruct the
text how to look and how it's formatted. In
addition, tags control graphics, animation, in
short… everything. For example the following
uses the <b> or bold tag:

HTML page in Code view

The cow jumped <b>OVER</b> the moon.
When displayed within a browser it would
look like this:
The cow jumped OVER the moon.
The start tag <b> instructs the text following the tag to use boldface; the end tag </b>
instructs the text to stop boldface and return
to normal.

HTML page in Design mode
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Using the Reference
Panel

It doesn't matter whether you're an experienced Web designer, or a
newcomer to the field. Sooner or later you're going to need a bit of
help, in the form of reference material. I'll admit that I'm a big reader…
I love to read. I have a library full of books on creativity and design.
Unfortunately, I can't carry all those books with me when I'm on a lecture tour. That's why one of my favorite features in Dreamweaver is the
Reference panel. The Reference panel gives you instant (on screen)
access to 10 O'Reilly reference manuals, 2 Adobe manuals, and a
UseableNet Accessibility Reference. Now that's a lot of reading material, and instant information at your fingertips. For example, you're coding a page, and you need a bit more information on the HTML body
tag… it's there, or you need a bit of help with the new syntax of
XHTML… it's there. As a matter of fact, when you first open the
Reference panel, the information displayed is based on the selected
element on the active Web page.

Access the Reference Panel
1

Open Dreamweaver (do not open a
document).

2

Click the Window menu, point to
Results, and then click Reference.

3

Select information based on the
following options:

2

◆ Click the Select Book list arrow

to select from the list of
available reference manuals.
◆ Click the Select Tag list arrow

to select from a list of available
HTML tags.
◆ Click the Select Attribute icon

to choose from a list of
available attributes for the
selected tag.
The reader window displays the
information based on your
selections.
3
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Access Specific Information
1

Open the Web page you want to
access specific information.

2

Perform one of the following:

1

2

3

◆ Code View. Select a specific

HTML tag, CSS style rule, or
other HTML text.
◆ Split View. Select an item in

the Code pane or select an
object or text in the Design
pane.
◆ Design View. Select an object,

graphic, or portion of text.
3

Select the element for which you
want specific information.

4

Press Shift+F1 (Shortcut for
accessing the Reference panel).
The panel opens and displays
information about the selected
page element.

Reference information for
the selected element

Did You Know?
You can search for tags, attributes, or
text in code. Click the Edit menu, click
Find And Replace, specify the Find in
document, select Source Code in the
Search list arrow, enter the text you
want to find, enter the replace text
(optional), specify any options, and
then click the Find or Replace buttons
you want.
You can save and reuse searches.
Click the Edit menu, click Find And
Replace, set the search criteria you
want, click the Save Query button (the
disk icon), navigate to the folder where
you want to save the search, and then
click Save. To reuse a search, click the
Load Query button (the folder icon),
navigate to the folder with the saved
search query file, select it, click Open,
and then use the Find or Replace buttons you want.
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Using Code View

Dreamweaver utilizes three document code views: Code and Design,
Code, and Split Code. The Code and Design view gives you a look at the
code and the visual design, the Code view gives you a straight look at
the HTML code of your Web page, and the Split Code view gives you a
multi-pane look at the HTML code. When you work in any of the code
views, you're going back to the basics of Web design… the actual
code that makes it all happen. Some designers never look at the code,
and some designers claim that you can't be good at creating Web
pages without knowing the code. To be honest, I'm in the second camp.
I believe that to really understand the design of a Web page, you need
to know how the code makes a page function.

Access the Code View
1
1

Open the Web page you want to
view code.

2

Access the Code view using one
of the following methods:

3

2

Code in Split view

◆ Code and Design View. Click

the View menu, and then click
Code and Design, or click the
Split View button on the
document window.
◆ Code View. Click the View

menu, and then click Code, or
click the Code View button on
the document window.
◆ Split Code View. Click the View

menu, and then click Split
Code.
The document view changes to
display the current page code.
3

To change the placement of
content in a split screen, click the
View menu, and then click Split
Vertically (horizontal when
unchecked), or Design View on
Left or Design View on Top.

Did You Know?
You can adjust the size of the panes in
Split view. Drag the splitter bar
located between the two panes.
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View Code in a Separate
Window Using Code Inspector
1

Open the Web page you want to
view code.

2

Click the Window menu, and then
click Code Inspector.

3

Use the toolbar to select from the
following options:

1

2

◆ File Management. Get, put,

check in or check out a file.
◆ Preview/Debug In Browser.

Preview or debug the file in a
browser or Device Central.
◆ Refresh Design View.

Refreshes Design view to
reflect code changes in Code
view.
◆ Reference. Opens the

Reference panel.
◆ Code Navigation. Allows you to

4

3

move quickly in the code.
◆ View Options. Allows you to

change the way code appears
in Code view.
4

When you’re done, click the Close
button.

Did You Know?
You can use the coder-oriented workspace. The workspace displays the
panel groups docked on the left side of
the main window, and the Document
window appears in Code view. The
Properties panel is collapsed. Click the
Window menu, point to Workspace
Layout, and then click Coder.
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Using Code Live View

As you work in Live view, you can also view live code. Similar to Live
view, Live Code view is a non-editable view. Live code view appears
displaying the code that the browser uses to execute the page. The
non-editable code is highlighted in yellow. If you want to edit the code,
all you need to do is return to Live view, and then switch to Code view,
which is editable. After making your code changes, you can return to
Live view and then refresh it to see your changes.

Access Live Code View
1

Open the Web page you want to
view.

2

Switch to Design view or Code and
Design view.

3

Click the Live View button.

4

To go to Live Code view, click the
Live Code button.

1

2

3

Live code view appears displaying
the code that the browser uses to
execute the page. The noneditable code is highlighted in
yellow.
5

To return back to Live view, click
the Live Code button again.

6

To return back to Design view,
click the Live View button again.
4

Did You Know?
You can print code. Open the Web
page you want to print in Code view,
click the File menu, click Print Code,
specify the options you want, and then
click OK (Win) or Print (Mac).

See Also
See “Previewing Pages in Live View”
on page 32-33 for more information on
viewing pages in Live View and Live
Code View.
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Setting Code View
Options

You can select Code view options to change the way code appears in
Code view. When you select the Code View Options command on the
View menu or use individual buttons on the Code toolbar, you can set
options to set word wrapping, display line numbers, hide characters,
highlight invalid code, color code, indent code automatically, and display syntax error alerts in the Info bar.

Use Code View Options
1

Open the Web page you want to
view code.

2

Switch to the Code view.

3

Click the View menu, point to Code
View Options, and then select
from the following options:

1

2

◆ Word Wrap. Forces the HTML

code to wrap, based on the
width of the Code view window.
◆ Line Numbers. Displays line

numbers to the left of the HTML
code.
◆ Hidden Characters. Displays

hidden code elements, such as
tabs and character returns.

3

◆ Highlight Invalid Code.

Highlights any code that
Dreamweaver considers
incorrect.
◆ Syntax Coloring. Colorizes the

HTML code, to visibly separate
it from the text.
◆ Auto Indent. Automatically

indents the HTML code to aid in
readability.
◆ Syntax Error Alerts in Info Bar.

Displays syntax code error
alerts in the Info bar.
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Entering HTML Code

You can enter HTML code in Code view like you are typing text into a
word processor. However, when you type HTML code, it uses a specific
structure and layout. As you type, the Code Hints popup menu appears
to help you enter correct HTML code tag names, attributes, and values
as you type code in Code view or the Quick Tag Editor. For example,
when a tag requires the selection of a color, Dreamweaver displays a
color palette. When a font is required, a font list is automatically displayed, and when a file is required a browse button magically appears
allowing you to select and insert the file. If a page does contain invalid
code, it appears in Design view and optionally highlights in Code view.
When you select the invalid code, the Properties panel displays information as to why the code is invalid and steps to fix it.

Enter HTML in Code View
1

Open the Web page you want to
view code.

2

Switch to the Code view.

3

Click to the right of a tag and press
Enter to create a space between
the opening and closing body tag.

4

Enter the HTML code you want on
the new line.

1

2

◆ Code Hints. When you type the

left brace "<" the Code Hints
popup menu appears, listing all
possible HTML codes. Begin
entering in the code name, and
Code Hints will display the
correct code. Double-click it or
select it and press Enter (Win)
or Return (Mac) to add the tag.
TIMESAVER Press
Control+Spacebar to display a
Code Hints popup menu or press
Esc to close the Code Hints menu.
5

To indent the selected code, press
Tab; to outdent the selected code,
press Shift+Tab.

6

To add a closing tag, type a left
brace and forward slash "</", and
Dreamweaver will automatically
insert the correct closing tag.

7

To remove a tag, right-click in the
tag, and then click Remove Tag.
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Using Code Hints

Code hints makes it easy to insert and edit code accurately in a variety
of languages. Dreamweaver supports code hinting for the following languages and technologies: HTML, CSS, DOM, JavaScript, Ajax, Spry,
Adobe ColdFusion, JSP, PHP (New! for functions, variables, and classes
and tooltip help), MySQL, ASP JavaScript, ASP VBScript, ASP.NET C#,
and ASP.NET VB. As you start to type code for a particular code type,
the Code Hints popup menu appears to help you enter it correctly. When
you type a right angle bracket (<), code hint displays HTML tag names.
When you type a period (dot operator) after an object, code hint displays JavaScript code possibilities. Dreamweaver also provides code
hinting for your own or third-party custom JavaScript classes that are
not built in to the language. If Dreamweaver detects problems with your
code, code hints doesn’t always work properly. Use the Syntax Error
Information Bar to help you fix the code problems.

Use Code Hints
1

Open the Web page you want to
view code.

2

Place the insertion point where
you want to add code.

3

Start to type the code you want or
press Control+Spacebar to
manually display the code hints
popup menu.

4

Scroll through the list by using the
scroll bar or pressing the Up
Arrow and Down Arrow keys.

5

To insert a code hint, double-click
an item, or select it and then press
Enter (Win) or Return (Mac).

1

2

◆ Press Backspace (Win) or

Delete (Mac) to dismiss the list
of code hints.
6

To edit code, delete the code, and
then start typing what you want to
use for code hints.

Code hints

See Also
See “Setting Code Hint Preferences”
on page 344 for more information on
setting options for code hints.
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Working with HTML
Head Tags

Each page contains information about the document in the head section. You can set the properties of head elements to control how your
pages are identified on the Web by search browsers. You can insert the
following head tags: meta, keywords, description, refresh, base, or link.
A meta tag records information about the current page, such as encoding, author, copyright, or keywords. The keywords and description tags
record information many search engines, such as Google or Yahoo,
look for to create an index for your page for use in their search results
databases. For the best results, specify a few descriptive keywords and
a short description for a page. The refresh tag specifies the amount of
time before the page is refreshed in a browser. The base tag sets the
base URL that all document-relative paths in the page use. The link tag
defines a relationship between the current page and another file. After
you insert a head tag, you can always make changes and adjustments
by using the head content, selecting the head element, and making
changes in the Properties panel.

View and Insert Head Tags
1

Open the Web page you want to
view and change head properties.

2

To insert head tags, click the Insert
menu, point to HTML, point to
Head Tags, and then select the tag
you want: Meta, Keywords,
Description, Refresh, Base, or Link.

3

Enter the information or specify
the options you want, and then
click OK.

4

Click the View menu, and then
click Head Content.

5

To edit an element, click one of the
icons in the head section to select
it, and then change the properties
you want in the Properties panel.

1

4

2

5

Did You Know?
You can check for balanced tags and
braces. In Code view, click to place the
insertion point where you want to
check, click the Edit menu, and then
click Select Parent Tag or Balance
Braces. You can select the commands
again to check the next level out.
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Inserting HTML
Comments

If you’re writing large sections of code or working with other people to
develop a site, it’s important to insert comments into your HTML code.
An HTML comment is descriptive text that explains the purpose and
process for the page’s code. The comment text only appears in Code
view; the information is for internal development purposes only. You
can insert comments in Code view or Design view. After you insert a
comment, you can edit it directly in Code view, or select the comment
marker and make changes in the Properties panel.

Insert HTML Comments
1

Open the Web page you want to
insert comments.

2

Click to place the insertion point
where you want to insert a
comment (in Code or Design view).

3

Click the Insert menu, and then
click Comment.

4

Type the comment you want.

5

Click OK (in Design view).

3

1

4

Did You Know?
You can change the code using the
Selection submenu. Select the code
you want in Code view, right-click
(Win) or control-click (Mac) it, point to
Selection, and then click the selection
command you want.
You can copy and paste code. Copy
the code from Code view or from
another program, click to place the
insertion point in Code view where you
want to paste the code, click the Edit
menu, and then click Paste.

2

5

See Also
See “Working with Invisible Elements”
on page 88 for information on displaying comment markers in Design view.
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Using the Coding
Toolbar

When you switch to Code or Split view, the Coding toolbar appears
along the left side of the Code view pane. The toolbar provides easy
access to the most common coding related commands. If the Code
view pane is not large enough, an expander arrow appears, which you
click to access additional buttons. Some of the tools allow you to collapse and expand the content between a set of opening and closing
tags, select tags, insert and remove comments, format code, and highlight invalid code.

Use the Coding Toolbar
1
1

Open the Web page you want to
view code.

2

Switch to Code or Split view.

3

Click to place the insertion point in
the code or select a block of code.

4

Click the button you want on the
Coding toolbar:

2

◆ Open Documents. Displays a

list of open documents. Click
the one you want to open it.

3

◆ Show Code Navigator. Displays

the Code Navigator in the code.
◆ Collapse Full Tag. Collapses

the content between a set of
opening and closing tags. You
need to place the insertion
point in the opening or
closing tag.
◆ Collapse Selection. Collapses

the selected code.
◆ Expand All. Restores all

collapsed code.
◆ Select Parent Tag. Selects the

code tag immediately outside of
the line with the insertion point.
◆ Balance Braces. Selects the

code tag and surrounding
parentheses, braces, or square
brackets of the line with the
insertion point.
◆ Line Numbers. Shows or hides

the numbers at the beginning of
each line of code.
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◆ Highlight Invalid Code.

Highlights invalid code in
yellow.
◆ Syntax Error Alerts in Info Bar.

Displays syntax code error
alerts in the Info bar.
◆ Apply Comment. Inserts

comment tags around the
selected code, or opens new
comment tags.
◆ Remove Comment. Deletes

comment tags from the
selected code.
◆ Wrap Tag. Wraps selected

code with the selected tag from
the Quick Tag Editor.
◆ Recent Snippets. Inserts a

Open Documents
Show Code Navigator
Collapse Full Tag
Collapse Selection
Expand All
Select Parent Tag
Balance Braces
Line Numbers
Highlight Invalid Code
Syntax Error Alerts in Info Bar
Apply Comment
Remove Comment
Wrap Tag
Recent Snippets
Move or Convert CSS
Indent Code
Outdent Code
Format Source Code

recently used code snippet
from the Snippets panel.
◆ Move or Convert CSS. Moves

CSS to another location or
converts inline CSS to CSS
rules.
◆ Indent Code. Shifts the

selection to the right.
◆ Outdent Code. Shifts the

selection to the left.
◆ Format Source Code. Displays

options to apply source code
formatting to selected code, or
to the entire page if no code is
selected. You can also access
Code Format Settings from the
Preferences dialog box or the
Tag Library Editor.
TIMESAVER You can perform
many of these same commands on
the Insert panel.

For Your Information
Identifying Syntax Errors
If you open a page with syntax errors, Dreamweaver displays a
semi-transparent red color to mark the code view gutter on all the
lines that have syntax errors. In addition, Dreamweaver displays an
alert message in the Info bar to inform you the first error line number and warn you that code hinting might not work property. It’s
important to know that even though all errors are shown, often only
the first error is the real error location. The rest of the errors are an
indirect consequence of the first error.

See Also
See “Moving CSS Rules” on page 226
for information on moving CSS rules to
a style sheet.
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Using Quick Tag
Editor

Creating Web documents in the Design view is a beautiful and elegant
way to design Web pages; however, sometimes you just need to get
under the hood and make changes directly to the code. Dreamweaver
gives you a way to make alterations to the code using the Quick Tag
Editor. When activated, the Quick Tag Editor displays as a small pop-up
window and allows you to edit a tag, add a tag, or enclose the current
selection within a tag. In addition, you can use a list of tags and attributes to help jog your HTML memory, and save you some typing.
Dreamweaver's Quick Tag Editor can be used in three ways: Insert
HTML (used for adding new tags and code at the current cursor position), Wrap Tag (wrap one tag around one or more other tags and content) and Edit HTML (displays the entire selected tag with all the
attributes). It is a great time-saver for making those small tweaks to the
code of any Web document. While most designers will perform most of
the creative process using the Design view, it's nice to know that you
have a powerful tool like the Quick Tag Editor when you need to get
back to coding basics.

Open the Quick Tag Editor
1

Open the Web page you want to
view code.

2

Open the Quick Tag Editor using
any of the following methods:

1

◆ Click the Modify menu, and

then click Quick Tag Editor.
◆ Use the keyboard shortcut
Ctrl+T (Win) or A+T (Mac).
◆ Click the Quick Tag Editor icon

in the Properties panel.

Did You Know?
Dreamweaver helps you with the syntax of the code. If you fail to add the
quotation marks around a parameter’s
value, the Quick Tag Editor will do it for
you. If you want to add more than one
tag, you can use the right arrow key to
move beyond the first set of braces in
the Quick Tag Editor. Then, simply enter
in a left brace and add the additional
tag.
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Use Quick Tag Editor in Wrap
Tag or Insert HTML Mode
1

Open the Web page you want to
view code.

2

Select a portion of text within the
document (for Wrap Tag mode) or
click in the text area (do not select
any text) to place an insertion
point (for Insert HTML mode).

3

Open the Quick Tag Editor.

4

Use the HTML tags in the pop-up
hint list to insert a tag, or manually
enter a customized XML tag.

5

Press Enter (Win) or Return (Mac)
to wrap the selected text with the
tag.

2

1

4

3

Use Quick Tag Editor in Edit Tag
Mode
1

Open the Web page you want to
view code.

2

Select a complete tag in Code
view (e.g., img), or select an
object, such as an image, in
Design view.

3

Open the Quick Tag Editor.

1

3

4

2

The tag with all its attributes will
be displayed within the Quick Tag
Editor window.
4

Manually enter any changes to the
tag and attributes.

5

Press Enter (Win) or Return (Mac)
to add the tag to the document.
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Using the Tag
Inspector

Dreamweaver's Tag Inspector gives you control over your code by displaying a collapsible outline of the tags used on the current page. This
feature allow you to quickly determine if tags are correctly nested, and
to view and change tag attributes. For example, you may want to
change the attributes of the <body> tag, or change the overall color
and size of the default font; both these and many more options are
available using the Tag Inspector. When selected, the Tag Inspector
displays a collapsible structure of all the attributes within the selected
Web element. This view gives you an overall view of the code and how
it's laid out. When you select a tag, all the attributes for that tag are
displayed for you to view and edit.

Access the Tag Inspector
1

Open the Web page you want to
view in the Tag Inspector.

2

Make a selection using one of the
following methods:

1

2

3

4

Tag Inspector

◆ Code View. Select a specific

HTML tag or section of text.
◆ Split View. Select a HTML tag

in the Code pane or select an
object in the Design pane.

5

◆ Design View. Select an object

in the window, or create a
selection of text.
3

Click the Window menu, and then
click Tag Inspector to display the
Tag Inspector.

4

Select from the following views:
◆ Category View. Displays a list

of general categories within
collapsible headings. Click the
plus (+) or minus (-) sign icon to
display all available attributes.
◆ List View. Displays a list of all

available attributes for the
selected Web element.
5

Select the attribute that you want
to add or modify, and enter the
correct value in the input field.

6

Press the Enter key to record your
changes.
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Using the Tag Chooser

Insert Tags Using the Tag
Chooser
1

Open the Web page you want to
insert a tag using the Tag Chooser.

2

Click to place the insertion point in
the code where you want to insert
a tag.

3

Right-click (Win) or control-click
(Mac) near the insertion point, and
then click Insert Tag.

4

Select a category of tags from the
tag library, or expand the category
and select a subcategory.

5

Select a tag from the right pane.

6

To view syntax and usage
information for the selected tag,
click Tag Info.

7

To insert the selected tag into your
code, click Insert.

8

If a tag requires more information,
enter the required information in
the tag editor, and then click OK.

9

Click Close.

The Tag Chooser allows you to insert any tag from the Dreamweaver
tag libraries in your page. A tag library is a collection of tags for a certain type that contains tag information, code hints, target browser
checks, and other features. You can insert tags from the following
types: HTML, CFML, ASP.NET, JSP, JRun custom library, ASP, PHP, and
WML. If you are looking for a specific tag in a specific category, the
Tag Chooser can help you insert it into your code with the right syntax.

2

1

3

4

5

Did You Know?
You can add or remove tags, attributes,
and libraries from the Tag Library.
Click the Edit menu, click Tag Libraries,
click the Plus (+) or Minus (-) buttons
to select commands to add or remove
tags, attributes, and libraries.

9
7

6
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Opening Related Files

If you have a related file attached to a document, you can use the
Related Files toolbar to quickly open it while keeping the main page
available. When the Enabled Related Files option and an Discover
Dynamically-Related Files option is selected in General Preferences,
Dreamweaver displays the names of all static and dynamically (New!)
related files related to a main document in a Related Files toolbar. The
related files include external CSS rules, server-side includes (multilevel), PHP files, external JavaScript files, parent templates files, library
files, and iframe source files. Status files appear first starting from the
left, followed by external files (such as .css and .js), and concluding
with dynamic path server included files (such as .php, .inc, and .module). When the Related Files toolbar contains too many files to fit on
the toolbar, scroll arrows appear on the right and left to access files.
To help you reduce the number of files on the toolbar, you can filter
files by type to hide the ones you don’t want to display. In addition,
when you click a link to a code source file in the Code Navigator, the
file appears in the related files area (if enabled).

Set Related Files Preferences
1

Click the Dreamweaver (Mac) or
Edit (Win) menu, and then click
Preferences.

2

Click the General category.

3

Select the Enable Related Files
check box.

4

Click OK to the alert. The change
takes effect after restarting
Dreamweaver.

5

Click the Discover DynamicallyRelated Files list arrow (New!),
and then select an option:

2

3

5

◆ Automatically. Displays static

and dynamically-related files on
the Related Files toolbar.
◆ Manually. Displays static

related files and displays the
Info bar for dynamic-related
ones. Click the Discover link on
the Info bar to display it on the
Related Files toolbar.
◆ Disabled. Turns off the

discovery of dynamicallyrelated files. Static related files
are still displayed.
6
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Use the Related Files Toolbar
Related Files toolbar with buttons to access files

◆

Open a Related File. Click a file
named button on the Related Files
toolbar.

◆

Open a Related File as a Separate
File. Right-click (Win) or Controlclick (Mac) a file named button on
the Related Files toolbar, and then
click Open as Separate File.

◆

Return to the Main Document
Source Code. Click the Source
Code button on the Related Files
toolbar.

◆

Filter Files on the Toolbar. Click
the Filter Related Files button
(New!) on the Related Files
toolbar, and then select the file
types you want to filter (checked
to show or unchecked to hide) or
click Show All File Types to show
all files.
The list of file types on the menu
is built based on the file types
connected to the current open
document. You cannot filter out all
the file types. When you close a
document, the filter settings are
not saved.

Filter Related
Files button

Filter settings

For Your Information
Using the Info Bar
The Info bar is a yellow bar that appears across the top of the main
document window, below the Document toolbar when certain types
of errors occurs in Dreamweaver. The Info bar (New!) shows information error messages for dynamically-related files, Live View, standard related files, code hinting, etc. For example, if a related file
doesn’t exist locally, the Info bar displays a Get link to download the
file, or if a related file isn’t checked out by you, the Info bar displays
a Checkout link to check out the files. Multiple Info bar messages
can be displayed. Clicking the scroll arrows takes you to the next
Info bar message. In Code view, the Info bar displays error messages in the current document. If you don’t way to view the errors,
you can turn them off by using the Syntax Error Alerts In Info Bar
button on the Coding toolbar.
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Navigating to Related
Code

Code Navigator displays a list of linked code sources related to a part
of a page. The related codes sources include internal and external CSS
rules, server-side includes, external JavaScript files, parent templates
files, library files, and iframe source files. When you click a linked code
source, the file appears in the related files area (if enabled) or opens as
a separate file in the Document window. If the code source is an internal CSS rule, the rule appears in Split view. You can open Code
Navigator from Design, Code, and Split views and the Code Inspector.

Open the Code Navigator
1

Open the Web page you want to
view.

2

Alt-click (Win) or commandoption-click (Mac) anywhere on
the page.

1

2

4

◆ You can also click the Code

Navigator indicator icon to
open the Code Navigator. The
Code Navigator indicator icon
appears near the insertion
point when the mouse remains
idle for 2 seconds.
The Code Navigator displays links
to the code related to the section
of the page you clicked. The code
sources are grouped by file and
listed alphabetically.
3

Click a link to display it in the
related files area or open it as a
separate file in the Document
window.

4

To close the Code Navigator, click
outside of it.

Did You Know?
You can enable or disable the Code
Navigator indicator. Alt-click (Win) or
command-option-click (Mac) on a
page, select or clear the Disable
Indicator check box, and then click
outside to close the Code Navigator.
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Setting Site Specific
Code Hints

When you’re working with PHP files in Dreamweaver, you can discover
code hints for functions, variables, and classes (New!). The built-in
hint support also includes tooltips with documentation from php.net,
which you can enable in Code Hints preferences. Added dynamic PHP
code hinting support allows you to customize CMS (Content Management System) frameworks, like Drupal, Wordpress, and Joomla. If a
PHP code hint is not available by default in Dreamweaver, you can create or edit a configuration file in your local site with the site-specific
code hints extension (New!) that allows PHP code hinting to inspect
the specified files and folders for functions, objects, and global variables you want as code hints. The configuration file, named
dw_php_codehinting.config, is saved to your site’s root.

Set Site Specific Code Hints
1

Open a PHP page, and make sure
a server site is set up.

2

Click the Structure list arrow, and
then select a built-in option
(Drupal, Joomla, or Wordpress), or
click <New from blank> to create
your own.

3

Click the Browse for Folder icon to
select a sub-root folder for the
configuration file and the base for
searches within the site.

4

To add or remove a file or folder to
your site scan, click the Plus
button, specify a file or folder, and
then click Add, or select a file or
folder, and then click the Minus
button.

5

4

2

6

3

5

7

Use any of the following:
◆ Scan This Folder. Includes the

selected folder in the site scan.
◆ Recursive. Includes subfolders

when a folder is selected.
◆ Extensions. Specifies the file

extensions to check.
6

To manage structures, use the
Import, Save, Rename, or Delete
buttons.

7

Click OK.
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Setting Code Hint
Preferences

You can use the Code Hint section of the Preferences dialog box to set
options for the Code Hints popup menu. Code Hints does more than help
you type in a simple HTML code tag. It helps you insert tag names,
attributes, and values as you type code in Code view or the Quick Tag
Editor. For example, when a tag requires the selection of a color,
Dreamweaver displays a color palette. When a font is required, a font
list is displayed, and when a file is required, a browse button magically
appears allowing you to select and insert the file. If you want additional
tooltip help, you can enable it for php code hints (New!).

Set Code Hint Preferences
1

Click the Dreamweaver (Mac) or
Edit (Win) menu, and then click
Preferences.

2

Click the Code Hints category.

3

Select from the following check
boxes:

2

◆ Close Tags. Select an option to

3

specify how you want to insert
closing tags. The default inserts
tags automatically after you
type the characters </. You can
also insert it after a final
bracket >, or not at all.
◆ Options. Select the Enable

Code Hints check box to use
code hints, and then drag the
slider to set the code hints
popup menu delay you want.
Select the Enable Description
Tooltips check box (New!) to
use tooltip help for PHP files.
◆ Menus. Select the check boxes

for the types of code hints you
want to display, and clear the
others you don’t want.
IMPORTANT Even if you
disable code hints, you can display
a popup hint in Code view by
pressing Control+Spacebar.
4

To add or remove tags and
attributes, click the Tag Library
Editor link.

5

Click OK.
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Setting Code Format
Preferences

You can use the Code Format section of the Preferences dialog box to
change the way your code looks in Code view. The options you set in
the Code Format section, except the Override Case Of option, are automatically applied only to new documents or additions to documents you
create in the future. If you want to reformat an existing document, you
can use the Apply Source Formatting on the Commands menu.

Set Code Format Preferences
1

Click the Dreamweaver (Mac) or
Edit (Win) menu, and then click
Preferences.

2

Click the Code Format category.

3

Select from the following options:

2

◆ Indent. Select to have Dream-

3

weaver indent generated code,
and then specify how many
spaces or tabs to indent.
◆ Tab Size. Specify how many

spaces for a tab character.
◆ Line Break Type. Select the

type of remote hosting server
(Windows, Macintosh, or UNIX).
◆ Default Tag Case and Default

Attribute Case. Select
<lowercase> or <uppercase>.

4

◆ Override Case Of: Tags and

Attributes. Select whether to
override your case settings.
◆ TD Tag: Do Not Include A Break

Inside The TD Tag. Select to
prevent problems with white
space and line breaks on older
browsers.
◆ Advanced Formatting. Click to

set formatting options for CSS
code and individual tags and
attributes in the Tag Library
Editor.
4

Click OK.
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Setting Code
Rewriting
Preferences

You can use the Code Rewriting section of the Preferences dialog box
to specify how and if Dreamweaver changes your code. Some of the
rewriting options allow you to fix invalid nesting and unclosed tags;
prevent duplicate names for form objects; ensure attributes values and
URLs contain legal characters; and add the right JavaScript tags upon
opening active content files. These options have no effect when you
edit your code in Code view. If you disable the rewriting options, invalid
HTML code that would have been rewritten is displayed in the
Document window.

Set Code Rewriting Preferences
1

Click the Dreamweaver (Mac) or
Edit (Win) menu, and then click
Preferences.

2

Click the Code Rewriting category.

3

Select from the following options:
◆ Fix Invalidly Nested and

Unclosed Tags. Select to
rewrite overlapping or
transposed tags and inserts
closing quotation marks and to
insert closing brackets as
needed.
◆ Rename Form Items When

Pasting. Select to prevent
duplicate names for form
objects.
◆ Remove Extra Closing Tags.

Select to delete closing tags
that don’t have an associated
opening tag.
◆ Warn When Fixing Or

Removing Tags. Select to
display a summary of invalid
HTML code Dreamweaver
wants to fix.
◆ Never Rewrite Code: In Files

With Extensions. Select to
prevent code rewriting in files
with specific file extensions,
and then specify the files
extensions you want separated
by a space.
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◆ Encode <, >, &, And “ In

Attribute Values Using &.
Select to make sure attribute
values you enter outside Code
view contain legal characters.
◆ Do Not Encode Special

3

Characters. Select to prevent
Dreamweaver from changing
URLs to use only legal
characters.
◆ Encode Special Characters In

URLs Using &#. Select to make
sure URLs you enter outside
Code view contain legal
characters (use the &#
encoding method).

4

◆ Encode Special Characters In

URLs Using %. Select to make
sure URLs you enter outside
Code view contain legal
characters (use the %
encoding method).
4

Click OK.
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Setting Code Color
Preferences

You can use the Code Coloring section of the Preferences dialog box to
specify colors for general categories of tags and code elements, such
as HTML Image or style tags, Library items, or CSS properties. For a
selected tag or code element, you can specify the text color, background color, and any formatting (Bold, Italic, or Underline) you want to
make it easier to work with your code. In Code view and Live Code
view (New!), you can specify different colors for backgrounds and
code to make it easier to read.

Set Code Color Preferences
2

1

Click the Dreamweaver (Mac) or
Edit (Win) menu, and then click
Preferences.

2

Click the Code Coloring category.

3

Click any of the color boxes, and
then select a color.

4

◆ Default Background. Default

5

Code view background color.
◆ Hidden Characters. Hidden
character code color. (New!)
◆ Live Code Background. Live

Code view background color.
(New!)
◆ Live Code Changes. Live Code

view code change color.
(New!)
◆ Read Only Background. Read
only background color. (New!)

4

Click the document type in which
you want to set code colors.

5

Click Edit Coloring Scheme.

6

Select the style for the document
type you want to change.

7

Specify the text color, background
color, and any formatting (Bold,
Italic, or Underline) you want.
The sample code in the Preview
pane displays the new styles and
colors.

8

Click OK.

9

Click OK.
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16

Developing iPhone Apps
Introduction
Apple has this device called an iPhone. Have your heard of
it? Of course you have. There is even a good chance you have
an iPhone. While the iPhone itself is an amazing piece of
technology, it is the software that makes the iPhone really
great.
The challenge in developing applications for the iPhone is
that you need to know how to develop using Apple’s Cocoa
Touch framework and the programming language Objective
C. One of the most interesting and talked about features in
Flash CS5 is Adobe’s inclusion of a tool that converts your
Flash movies to files that will run on any iPhone OS device
without needing to know Objective C. You just need to apply
the Flash and ActionScript knowledge you already have. A
new tool in Flash CS5, called the iPhone Packager, converts
files into valid iPhone applications.
Before you can create an iPhone App there are several
activities you need to complete so you can develop in Flash
CS5. They are (1) Become a Certified Apple Developer, (2)
Create a Development and Developer P12 certificate, and (3)
Register your development iPhone with Apple.
In this chapter, you’ll get an overview for how to start
developing for the iPhone using Flash CS5 including deploying an App to the iTunes App Store.

What You’ll Do
Become an Apple Certified Developer
Register an iPhone and other Apple
Testing Devices
Create App’s ID
Create a Developer’s Provisioning
Profiles
Create and Publish an iPhone App
Control the Accelerometer
Save Images to the Camera Roll

16
Understand the Limitations of Flash
Identify Devices to Deploy an Ad
Hoc App

Create an Ad Hoc Distribution Profile
Package an Ad Hoc App

Use iTunes Connect to Publish an App
Use Screen Orientation in an App
Use Geolocation in an App
Use Multitouch in an App
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Becoming an Apple
Certified Developer

The iPhone OS has rapidly become the mobile operating systems
against which all other mobile systems, such as Android, Windows
Mobile 7, BlackBerry, WebOS and Symbian, are all compared to. There
is a very good reason for this: the iPhone OS is rock solid. Each App
you develop for the iPhone OS will run on an ever increasing number of
products shipping from Apple. They include the iPhone 3G and 3GS,
iPod Touch and the iPad. All of your Flash CS5 applications (New!) will
run on these devices. To be able to develop applications for the iPhone
you do need to become a registered Apple developer. The cost is only
$99 a year and this gives you the ability to load applications up to the
iTunes App Store. Yes, you heard me right; it only costs $99 a year to
load as many apps as you can develop into the iTunes App Store. This
is an amazing deal. Similar programs run by Nintendo to develop apps
for their Wii Wares store start in the low thousands of dollars.

Become an Apple Certified
Developer
1

Open your Web browser on the
Mac, and then go to the iPhone
Dev Center site:

2

◆ http://developer.apple.com

/iphone
IMPORTANT Use a Mac for
these steps. later work can be
done on a Windows computer.
2

Click the Register link on the Web
page.

3

Follow the registration process;
either use an existing iTunes
Account or create a new account
to register with the site.
◆ Upon completion, you’ll receive

an email confirmation.
4

Go to http://developer.apple.com
/iphone/manage/certificates to
download and install your Apple
iPhone Development Certificate.

5

Open the Keychain to view your
Apple iPhone Development
Certificates: a Developer and a
Distribution Certificate.
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6

Control-click on the Developer
Certificate, and then click Export
Certificate.

7

Navigate to the location where
you want to save the certificate.

8

Click the File Format list arrow,
and then click Personal
Information Exchange (.p12).

9

Click Save.

6

10 Enter a strong password for your

App, and then remember it as
you’ll need it later.
7

11 Repeat Steps 6-10 to export the

Distribution Certificate in the
Personal Information Exchange
(.p12) format.

8

9

Did You Know?
You can use the P12 Certificates on
Windows. You can copy the P12
Developer and Distribution Certificates
to a disc and use them on a Windows
computer. Creating the P12 Personal
Information Exchange Certificates can
be done on a Windows computer, but it
requires the use of third party software
such as OpenSLL. It is not easy. You
are much better off starting with a Mac
(find a friend, if you need to) and then
moving to a Windows computer for
your future Flash CS5 iPhone development needs.

For Your Information
Developing Apps on Macs and Windows
Amazingly, Adobe is the only company that allows you to develop
iPhone Apps on Windows. All you need to accomplish this is to use a
P12 Developer and Publishing certificate. The easiest way to get a
P12 certificate is from a Mac computer. Just ask a friend if you can
create an account on their Mac and then register yourself with
Apple’s Development program and create your own P12. After that
you can copy the P12 certificate onto your Windows machine and
develop the iPhone Apps.
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Registering an iPhone
and Other Apple
Testing Devices

Find your iPhone’s Unique
Identifier
1

Connect your test iPhone/iPod
Touch to your computer.

2

Open iTunes, and then select your
device from the list to view the
Summary tab information.

3

Click the Serial Number next to
your device.
The number changes to an
Identifier (UDID) number, which
is. about 40 alpha-numeric
characters long.

4

Copy the UDID number.

5

Open your Web browser, and then
go to the Devices page on the
iPhone Developer site:
◆ http://developer.apple.com

/iphone/manage/devices
/index.action
6

Click the Add Devices button.

7

Paste in the UDID number and
then enter a name for your device.
◆ Suggestion: you may want to

choose something like “iPhone
Development” or “iPod Touch
Gen 3 Development.”
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The hardest part of developing apps for the iPhone is not the code you
develop, but ensuring you have all of your i’s and t’s dotted and crossed
per Apple’s rigorous registration process. One small step in the wrong
direction and your App will not compile or install correctly. It is worth
taking your time to go through the setup process (New!). After you
have your P12 Certificates you will need to register your test iPhone
with Apple. You can register up to 100 devices per year. The developer
account ID, registered device and P12 certificates are needed for all
apps your want to sell in the iTunes App Store. You can register
iPhone’s, iPod Touches and iPads.
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Creating App ID’s

The App ID is a unique identifier Apple uses to identify your App from
the tens of thousands of Apps in the iTunes App Store. There are ten’s of
thousands of applications in the iTunes App Store with more in constant
development. Part of your registration process is to assign your App an
ID, called the App ID. The App ID (New!) will be connected to your certificate and to the development and publication profiles you generate.
You control the name of the App, but behind the scenes, Apple associates it an unique ID, called a Bundle Seed ID. Apple will know what your
App is when it comes time for you to submit your App to iTunes.

Create an App ID
1

Open your Web browser, and then
go to the App ID page on the
iPhone Developer site:
◆ http://developer.apple.com

/iphone/manage/bundles
/index.action
2

Click the New App ID button.

3

Enter a new App name you can
find easily, such as
WorldlyWordSearch; the name has
to be all one word.

4

Enter a Bundle Seed ID.

2

◆ The convention is to reverse

your Web site address and add
your Apps name at the end.
For example, com.pearson.
worldlywordsearch; the name
has to be all one word.
5

Click OK.
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Creating a Developers
Provisioning Profiles

A provision profile is a document which is associated with your App
and developer certificate for either development or iTunes App distribution. There are three types of Provisioning Profiles (New!) you can use:
Developer, Distribution to Ad Hoc and Distribution to iTunes App Store.
You will cover how to use the Distribution Profiles later in the chapter.
For now, let’s focus on creating Developer Profiles.

Create a Developer Profile
1

Open your Web browser, and then
go to the Provisioning Profiles
page on the iPhone Developer site:

1

2

◆ http://developer.apple.com

/iphone/manage/provisioningpr
ofiles/index.action
2

Click the Development tab.

3

Click the New Profile button.

4

Enter a meaningful Profile name.

3

A convention that is gaining
popularity is to use the prefix
“Dev” followed by the App ID,
such as DevWorldlyWordSearch.
5

Select the check box with your
name in the Certificates list.

6

Click the App ID list arrow, and
then select your App ID.

7

Select your test device from the
devices listed.

8

Click the Submit button.
Your developer profile takes about
30 seconds to generate.
4
6

8

5
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Click Download (Mac) or Save
(Win), and then save the
Developer profile to your desktop.
The file will have the extension
“mobileprovision”

10 Connect your test iPhone to

iTunes.
11 Drag the downloaded Developer

Profile onto iTunes, and then sync
your iPhone.

9

This adds the Developer Profile to
your testing device.

For Your Information
Developing Icons for your iPhone Apps
In preparation for your iPhone App there are four PNG images you
need:
29.png – a file that is 29x29 pixels
57.png – a file that is 57x57 pixels
512.png – a file that is 512x512 pixels
Default.png – this place holder file that is used while your App
is loading. It is important the file starts with a capital “D”.
You can create all of these files using Adobe Fireworks.
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Creating and
Publishing an
iPhone App

With all of these tasks completed you are now ready to complete your
first iPhone App. Sometimes it seems like a world full of red tape where
you need to dot your i’s and cross your t’s, but you do get to the point
where you can develop applications for your iPhone using Flash CS5
(New!). You need to go through the steps of creating a Developer
Certificate, registering your test iPhone, creating an App ID, and downloading a developers profile in order to develop for any iPhone development tool; this is not just a unique Flash CS5 feature. Flash CS5,
however, does allow you to very easily create the final iPhone App.

Create and Publish an
iPhone App
1

In Flash, click the File menu, click
New, click iPhone OS, and then
click OK.

1

A new movie opens with the size
320x480 pixels.
2

Create an iPhone App using Flash
tools.

3

Open the Properties panel.

4

Click the iPhone Settings Edit
button.
3

The iPhone Settings dialog box
opens, displaying three tabs:
General, Deployment and Icons.
5

Click the General Tab.

6

Enter an Output file name, such as
wordsearch.ipa.

7

Enter the App Name that you want
to appear on the iPhone, such as
Word Search. You are limited to 11
characters.

8

Enter an version number for the
App, such as 1.0.

9

Click the Aspect Ratio list arrow,
and then select a display option:
Portrait or Landscape view.

10 Select or deselect any of the

following options:
◆ Full Screen. Select to force

your App to take up all of the
screen space on your phone;
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deselect to show information at
the top of your iPhone,
including carrier signal, WiFi
connection, time and battery
life, will be visible in your App.

5

13

18

6

7

8

◆ Auto Orientation. Select to

change the orientation of your
App as the iPhone is rotated.
11 Click the Rendering list arrow, and
9

then click an acceleration option,
Auto, CPU, or GPU.

10

12 Click the Add button (+) in

Included Files, and then select the
Default.png file. The Default.png
file displays when your App starts
to run and disappears when your
App has loaded.

11

13 Click the Deployment tab.
14 Click Browse, and then select your

Developer P12 certificate file, and
then enter your password.
15 Click Browse, and then select the

developer Provisioning Profile you
downloaded.
16 Enter the full name of the App ID

20

12

you created in the iPhone
Developer Center.
17 Select the Quick Publishing For

Device Testing option.

For Your Information

18 Click the Icons tab.
19 Locate and add the 29.png, 57.png

and 512.png file.
20 Click Publish.

Flash launches the iPhone
Packager tool and generates (6-10
minutes) an IPA iPhone App file in
the same folder as your Flash files.

Playing Back Video
You can play back video in the iPhone, but there is a caveat. The only
types of video that you can add to your iPhone Apps are Sorenson
and ON2 VP6 video formats. If you want to use H.264 then you need to
essentially post the video to a URL string so it pops up in Mobile
Safari.

21 Locate the IPA file, and then drag

the file onto iTunes and sync your
device. When the sync completes
you will be able to launch your
App from your iPhone.
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Controlling the Accelerometer
With the release of the Flash Player 10.1 and
Adobe Integrated Runtime, AIR 2.0, the Flash
team added several new core API features
(New!). Access to a devices Accelerometer is
one of those. The role of the Accelerometer is
to detect when you move your phone. The
Accelerometer is a listener that is triggered
when it is used. The following example adds
an Accelerometer listener to your iPhone App.

8

function checksupport():void {
if (isSupported) {
myTextField.text = "Accelerometer feature
supported";
acc1.addEventListener
(AccelerometerEvent.UPDATE, updateHandler);

Add an Accelerometer Listener
1

2

3

Create a new iPhone App and add the
necessary development properties in the
iPhone settings.
Add a dynamic text field to the Stage
with the name myTextField in the
Properties panel.
Create a new layer on the Timeline with
the named Actions, and then select the
Actions layer.

4

Open the Actions panel.

5

Add code to import the libraries for the
Accelerometer to work correctly:
import flash.events.AccelerometerEvent
import flash.sensors.Accelerometer;

6

Add code to create a new Accelerometer
object:
var acc1:Accelerometer = new Accelerometer()

7

Add a boolean object to test if the
Accelerometer works or not:
var isSupported:Boolean =
Accelerometer.isSupported;
checksupport();
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Add a function that contains the event
listener, which waits for the
Accelerometer to be triggered:

} else {
myTextField.text = "howdy ";

}

}
9

Add a function that posts a message to
the text field to tell what direction the
device has moved to:
function
updateHandler(evt:AccelerometerEvent):void {
myTextField.text = String("at: " + evt.timestamp
+ "\n" + "acceleration X: " + evt.accelerationX
+ "\n" + "acceleration Y: " + evt.accelerationY
+ "\n" + "acceleration Z: " +
evt.accelerationZ);

10 Publish and package your file into an

iPhone App and test it on your iPhone.
The Accelerometer gives you new ways
for your customers to interface with your
applications beyond touchscreen controls. The
Accelerometer works great on the iPhone but
the same code can be used for Adobe AIR
apps running on Google’s Android OS, Palm’s
WebOS and RIM’s BlackBerry phones. Yes,
that’s right. Develop one App and have it
deployed to multiple mobile devices.
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Saving Images to the Camera Roll
Adobe does give you access to some core
iPhone specific tools. One of those is the ability to add a function that will save an image
of the screen to the Camera Roll (New!). The
following example saves a screen image to
the Camera Roll in an iPhone App.

var cameraRoll:CameraRoll = new
CameraRoll();
cameraRoll.addEventListener(ErrorEvent.ERROR
, onCrError);

Save a Screen Image to Camera Roll

var bitmapData:BitmapData = new
BitmapData(stage.stageWidth,stage.stageHeigh
t);

1

Click the File menu, click New, click
iPhone OS, and then click OK.

2

Create a new Movie Clip on the Stage
with the name snapShot.

3

Add the following event Listener to:

cameraRoll.addEventListener(Event.COMPLETE,
onCrComplete);

bitmapData.draw(stage);
cameraRoll.addBitmapData(bitmapData);
}

snapShot.addEventListener(MouseEvent.CLICK,
myScreenShot);
4

else
{

Add the following function that takes a
screen shot of your iPhone:

trace("not supported.");

function myScreenShot
(event:MouseEvent):void
{
if (CameraRoll.supportsAddBitmapData)

}
}
5

Publish and package your file into an
iPhone App and test it on your iPhone.

{
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Understanding the Limits of Flash
There are some limitations to using the
iPhone Packager for Flash CS5 (New!). The
first is that you cannot load external SWF
movies. You can, however, load external JPG
and PNG files and sound files such as MP3.
There are also performance problems
between different versions of the iPhone. For
instance, the iPhone 3GS is literally twice as
fast as the iPhone 3G and original iPhone.
There some simple tricks you can do to speed
up things. The following code will prevent
event Bubbles starting:
override public function
dispatchEvent(evt:Event):Boolean {
if (hasEventListener(evt.type) || evt.bubbles) {
return super.dispatchEvent(evt);
}
return true;
}
A second optimization trick you can do is
to restrict your use of vector based images
inside of Flash. Use PNG formatted images
where possible. The good news is that that the
iPhone has great support for PNG files.
If you do need to use vector images you
can fool the iPhone into thinking it’s a bitmap
image by using the cahceAsBitmapMatrix.
1

Create a new image. Add code import the
Flash Geom Matrix:
import flash.geom.Matrix;

2

Create a new shape:
var my_shape :MyShape = new MyShape();
addChild(my_shape);

3

Add the cachasBitmap property to ensure
that all objects that create are cached:
my_shape.cacheAsBitmap = true;
my_shape.cacheAsBitmapMatrix = new
Matrix();
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Create images on the screen that the
iPhone thinks are bitmaps.

A final significant limitation is the use of
audio files. Audio files can have a short delay
between an event happening and the sound
playing. This is because the audio file is not in
the iPhone’s cache for playback. You can avoid
this by exporting your audio file to be triggered in the first frame of your movie.

What Flash Does Not Allow You To Do
Adobe has gone to great lengths to allow you
to build applications for the iPhone using traditional Flash tools. BUT (and it is a big BUT)
there are some things that Flash does not
allow you to do using the iPhone Packager.
The biggest challenge you will have is the
inability to use ActionScript 1.0 and 2.0. All of
your apps must be developed using
ActionScript 3.0. There are tens of thousands
of great ActionScript 1.0 and 2.0 apps that can
not be published to the iPhone due to the
ActionScript 3.0 limitation.
You also have to be careful using video.
Only Flash Video will work. You can use a URL
link to load a MPEG4 video, but this is really a
cheat as you are running the video through
the iPhone’s Mobile Safari Web browser.
If you are familiar developing iPhone Apps
using the iPhone SDK then you may expect
core iPhone Cocoa Touch kits available to you
in Flash. This includes the StoreKit (for “in
App purchase”), GameKit, MapKit and other
rich media tools. These useful kits are simply
not available to the Flash developer.
The good news is that Adobe is well aware
that the Flash CS5 iPhone Packager is not
complete. Expect releases for the iPhone
Packager to keep coming during the lifecycle
of Flash CS5.
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Identifying Devices
to Deploy an Ad
Hoc App

Collect and Add Deployment
Device IDs
1

Ad Hoc is a method for deploying your App to up to 100 iPhone, iPod
Touch and iPad devices. The Ad Hoc method (New!) is a solution that
allows you to deploy your apps to a small group of friends and co-workers without the App appearing in the iTunes App Store. The method for
creating the application is very similar to deploying an App for deployment to the iTunes App store. There are three steps you need to be able
to successfully deploy an App using Ad Hoc: Identify each device you
will be deploying your Ad Hoc App too; creating an Ad Hoc provisioning
license; and packaging your Ad Hoc App.

2

Contact each person you will be
deploying your App to and ask
them to connect their iPhone, iPod
Touch or iPad to their Mac or
Windows computer.

2

Ask them to open iTunes, select
their device, and then view the
Summary tab information.

3

Ask them to click the Serial
Number next to their device.

4

The number changes to an
Identifier (UDID) number.
4

Ask them to copy the UDID
number, and then send it to you.

5

Open your Web browser, and then
go to the Devices page on the
iPhone Developer site:

Added trusted devices

5

◆ http://developer.apple.com

/iphone/manage/devices
/index.action
6

For each trusted device, click the
Add Devices button on the Web
page, paste in the UDID number
and then enter a device name.

6

IMPORTANT You can only have
100 identified devices per year.
You cannot add and remove
devices to keep your list at 100.
When you have added the 100th
device you have to wait a year
before you can remove a device
and add a new one.
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Creating an Ad Hoc
Distribution Profile

Create an Ad Hoc Distribution
Profile
1

The first step is to identify the devices you will be deploying your Ad
Hoc App to. The next step is to create the profile you will need to use
when you are building your Application for Ad Hoc deployment. The Ad
Hoc Distribution method (New!) removes the hassle of having to wait
for your App to be approved by Apple (which can take days to weeks to
complete). To be able to take advantage of the Ad Hoc deployment
process you need to first create an Ad Hoc Distribution Profile.
Creating the Ad Hoc Profile is very similar to the profile you will create
when you submit your App to the iTunes Store. The one big difference
is you need to have a list of all the unique iPhone's and iPod Touch
devices you will be sending your final App too.

1

2

4

Open your Web browser, and then
go to the Provisioning Profiles
page on the iPhone Developer site:
◆ http://developer.apple.com

/iphone/manage/provisioningpr
ofiles/index.action
2

Click the Distribution tab.

3

Click the New Profile button.

4

Click the Ad Hoc option.

5

Enter a profile name for your App.

6

Click the App ID list arrow, and
then select the App ID that
matches the App you want to
deploy using Ad Hoc.

7

Select the devices (from the list of
ones you entered) you want to
deploy using Ad Hoc.

8

Click the Submit button.
Your Ad Hoc profile takes about 30
seconds to generate.

9

Click Download (Mac) or Save
(Win), and then save the Ad Hoc
profile to your desktop.
At this point, you’re ready to
create your Ad Hoc iPhone App.
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Packaging an Ad
Hoc App

Publish and Package an
Ad Hoc App
1

In Flash, open the iPhone App you
want to publish and package as an
Ad Hoc App.

2

Open the Properties panel.

3

Click the iPhone Settings Edit
button.

The final step you need to take is to package your Flash movie into an
iPhone App using the Ad Hoc profile (New!). The final step in creating
your Ad Hoc App is to package your Flash App for distribution. The Ad
Hoc distribution process is very similar to the final App Store Packaging
publication process. There are some differences. The main change is
that you must use the Ad Hoc Profile you created in the previous section. Without the Ad Hoc Profile your Ad Hoc deployment method will
not work correctly.

4

5

The iPhone Settings dialog box
opens, displaying three tabs:
General, Deployment and Icons.
4

Click the Deployment tab.

5

Click Browse, and then select your
Published P12 certificate file, and
then enter your password.

6

Click Browse, and then select the
Ad Hoc Distribution Profile you
downloaded.

7

Click the Deployment – Ad Hoc
option.

8

Click Publish.
Flash launches the iPhone
Packager tool and generates (6-10
minutes) an IPA iPhone App file in
the same folder as your Flash files.

6

7

8

10 Locate the IPA file and send it to

anyone in the Ad Hoc Provisioning
Profile list. Ask them to drag the
file onto iTunes and sync their
device. When the sync completes
you will be able to launch your
App from your iPhone.
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Packaging an App for
the iTunes App Store

Publish and Package an
iPhone App
1

Apple’s iTunes Store is an amazing success story. 133,000 Apps and 3
Billion downloads in 20 months is nothing to sneeze at. There are many
stories of companies making millions from Apple. But, before you can
get any money, you need to have your App ready for deployment. The
method for packaging your Flash file into an iPhone App for distributing
to the iTunes store is very similar to the Ad Hoc process with the
exception that you only need to create a distributing profile and create
your iPhone IPA file from Flash CS5 (New!) .

1

2

Open your Web browser, and then
go to the Provisioning Profiles
page on the iPhone Developer site:
◆ http://developer.apple.com

/iphone/manage/provisioningpr
ofiles/index.action
2

Click the Distribution tab.

3

Click the New Profile button.

4

Click the App Store option.

5

5

Enter a profile name for your App.

6

6

Click the App ID list arrow, and
then select the App ID that
matches the App you want to
deploy.

7

Click the Submit button.
Your profile takes about 30
seconds to generate.

8

Click Download (Mac) or Save
(Win), and then save the App Store
profile to your desktop.

9

In Flash, open the iPhone App you
want to publish and package as an
App Store App.

10 Open the Properties Panel.
11 Click the iPhone Settings Edit

button.
The iPhone Settings dialog box
opens, displaying three tabs:
General, Deployment and Icons.
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12

12 Select the Deployment tab.
13 Click Browse, and then select your

Published P12 certificate file, and
then enter your password.
14 Click Browse, and then select the

App Store Distribution Profile you
downloaded.
13

15 Click the Deployment – Apple App

Store option.
16 Click Publish.

14

Flash launches the iPhone
Packager tool and generates (6-10
minutes) an IPA iPhone App file in
the same folder as your Flash files.
17 Locate the IPA file and then

change the extension of the file
from IPA to ZIP.
Both file formats are container
formats. That is, they contain all of
the files needed for the App to run;
iTunes Connect only accepts files
in the ZIP format.
At this point, your App is ready for
deployment to the iTunes App
Store.

15

16

Did You Know?
Ad Hoc is a great way to easily deploy
apps to a small group of users. It is not
a good solution for deploying apps to a
large number of users. If you want to
deploy your App to a large number of
users then you will need to take advantage of Apple’s powerful iTunes App
Store.
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Using iTunes Connect
to Publish an App

You are now very close to having an App available on the iTunes store.
Can’t you feel the rush! You could be selling thousands of apps in a matter of a few days. The gap between you and riches is Apple’s iTunes
Connect publishing tool. You are very close now. You will be using a new
Web site to upload your final iPhone Apps. The site is called iTunes
Connect (https://itunesconnect.apple.com/). In every sense, iTunes
Connect is your business relationship with Apple. The site allows you to
set up your contracts, tax records, banking information, review sales
trends, download financial report and manage your In App Purchases.
You will need to complete these sections in order to sell your App in
iTunes. This section is going to focus on the important part of iTunes
Connect: Managing your Applications (New!).

Use iTunes Connect to Publish
your App
1

In Flash, create your iPhone App,
publish and package it, and then
change the extension from IPA
to ZIP.

2

Convert the 512x512 PNG pixel
image into a JPG image. Label the
new file 512.jpg.

3

Take a screen shot of your App as
it appears in your iPhone. When
your App is playing on your
iPhone, press the Home and Sleep
buttons at the same time (screen
flashes) to take a screen shot of
your App.
The image is stored to your
Camera Roll and is exactly the
same size Apple needs.

Did You Know?
You can download Apple’s Developer
Guide. Open your Web browser, go to
the Manage Your Application page on
iTunes Connect, and then click the
download link to save the PDF file.
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Open your Web browser, and then
go to the iTunes Connect page,
and then use your Apple
Developer ID and Password to
log into the site:

6

◆ https://itunesconnect.

apple.com
5

Click Manage Your App from
iTunes Connect.

6

Add anew application or edit an
existing one.
◆ Add New App. Click the Add

New Application button to
start the process of creating
a new iTunes App.
◆ Edit Existing App. Double-click

the application icon.
When you’re done editing your
App settings, click Save
Changes.

Link to download the Developer Guide

There are several screens you
need to complete to upload your
App to iTunes.
7

If prompted, click the Yes or No
option to specify whether your
App contains encrypted data.
◆ For a first App, click No to keep

the process simple. In the
future, you can experiment with
different settings.
8

Click the Continue button when
you have completed the page.
The next page allows you to add
product overview information
about your App. For the most part,
the content you enter on this
screen can be edited after your
App has been submitted.

7

8

Continue Next Page
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Continued from Previous Page
9

9

Enter or change information about
your App. The information includes
the following:
◆ Name and description.
◆ Product primary and secondary

categories.
◆ Copyright, version number, and

SKU number.
◆ Keywords. Use for search
engines (up to 100 characters).
◆ URLs. Application/support URL
and support email.
10 Click the Continue button when

you have completed the page.
The next page allows you to add a
rating for your App.
11 Click options to answer the 10

questions to determine a rating.
12 Click the Continue button when

you have completed the page.
The next page allows you to
upload all of your App files.
13 Click the Choose File button to

upload your App files:
◆ Upload the ZIP’d IPA file for the

Application.
◆ Upload the 512.jpg for the Large

512x512 Icon.
◆ Upload a 480x320 jpg image for

the Primary Screenshot.
◆ Add 1-4 480x320 jpg images for
the Additional Screenshots.
The upload will take about 20
minutes. The upload is checking
for some basic settings such as
including the correct profile.
A green check mark appears for
each successfully loaded image.
A red cross appears when
something is wrong.
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14 Click the Continue button when

15

you have completed the page.
The next page allows you to
specify availability and pricing for
your App.
15 Specify an Availability Date and

Price Tier.
◆ Availability Date. Specifies

when your App goes on sale.
◆ Price Tier. Select a price tier

level; you do not get to select a
specific price for your App.
This removes the pain of selling
with different currencies. A Tier
2 App will be $0.99 in the US, 59
pence in England and AU$1.29
in Australia. There are over 70
different currencies that Apple
manages for you.

17

16 Click the Continue button when

you have completed the page.
The next page allows you to
specify localization for your App.
17 Specify the localization settings

you want for your App.
18 Click the Continue button when

you have completed the page.
19 At this point, review all of your

content, and then click the
Submit button.
◆ When you’re done editing your

App settings, click Save
Changes.

Did You Know?
Faster iTunes App Submission. Apple
has done a lot to improve the review
process for new apps. Today it only
takes 5-7 days for an App to be
approved and appear in iTunes.
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Using Screen Orientation in an App
The iPhone has one characteristic that you will
not see on a desktop or laptop computer: it
can be easily rotated. Determining orientation
can allow you to add interesting effects to
your iPhone Apps (New!). For instance, the
default Stocks tool on your iPhone will show
you the numbers of a particular stock when
you hold your phone in portrait; switch the
phone to landscape and the content changes
to a line chart illustrating how the stock is performing. This trick is accomplished through
the iPhone being able to detect the orientation
of the device. The iPhone can detect
Orientation in four distinct directions:
◆

Default – Portrait

◆

Rotation Left – Landscape

◆

Rotation Right – Landscape

◆

Upside Down – Portrait, upside down

ActionScript contains a special class called
the Orientation Class, which allows you to
control content on the screen depending on
the orientation of the device.

Use the Screen Orientation Class
1

406

Create a new iPhone App, apply the
appropriate provisioning profiles, and
then save the file with the name
iPhoneOrientation.fla.

2

Add a dynamic text box to the Stage with
the name myTxt, and then apply the
_Sans font.

3

Open the Actions Panel.

4

Add a listener and function that changes
the content of the text box based on the
orientation of the device (see illustration).

5

Publish and package your file into an
iPhone App and test it on your iPhone.
Rotate your iPhone to see the text change
on your iPhone.

Chapter 16

In addition to using ActionScript to control
the orientation of your phone, you can also
have the whole movie auto-orientate as a
default setting in your iPhone Settings screen.
On the whole, however, you have much
tighter control over your content is you use
ActionScript to control the orientation of specific movies, sprites and objects over the
auto-orientation Boolean setting.

For Your Information
Loading Files Into the iPhone
The Loader Class allows you to load external content into your Flash Player. For the most part, this
still works when you package your Flash movie for
the iPhone. For instance, you can still load MP3,
Sorenson Flash video and PNG files. There is,
however, one exception: you cannot load SWF files
that contain ActionScript into your movies. This is
a pain as a lot of Flash designers like to break up
their movies into smaller, individual SWF files and
then you use a shell SWF to package it all
together. Hopefully that will change in future
releases.

C16FLCS5.qxp

4/5/2010

6:08 PM

Page 407

Using Geolocation in an App
Mobile devices are meant to move. With
GeoLocation services, you can figure out your
current location. So, when someone asks you
“Where are you?” you can tell them.
The following example shows how to add
Adobe AIR 2.0 GeoLocation Class (New!) to
your iPhone App. This sample is stripped
down to a simple Class file, which can give
you an idea of how you can use this in other
Apps.

informing the user that a location could
not be detected. If you do, however,
allow the user to use geolocation then a
new listener event will be triggered and
then re-run 10x/second.
8

Add a function triggered by the
geolocation listener:

9

Publish and package your file into an
iPhone App and test it on your iPhone.

Add GeoLocation Services
1

Create a new iPhone App, apply the
appropriate certificates and profiles, and
then save your file with the name
iPhoneGeolocation.fla.

2

Add a dynamic Classic Text box to the
Stage with the name myTxt, and then
apply the _Sans font.

3

Create a new Class for the App with the
name iPhoneGeolocation.

4

Save the ActionScript file with the name
iPhoneGeolocation.as.

5

Add code to import the class files that
allow you to use the Geolocation objects:
import flash.events.GeolocationEvent;
import flash.sensors.Geolocation

6

Create a new geolocation variable that
you can use:
private var myGeo:Geolocation;

7

Create a simple If/Else statement that
detects whether or not the geolocation
services can be used.
The iPhone always gives the user of the
iPhone a choice to whether or not you
can use the Geolocation services. If you
do not allow geolocation to be used a
message will be posted to the text field

How Does the iPhone Know Your
Location?
There are three ways to detect your location.
The most accurate method uses the Global
Position Satellites (GPS) built into the iPhone
3G and 3GS. The second method uses Cell
Tower Triangulation where the location of the
device is determined by using 3 or more Cell
Tower’s. This method can be used by all
iPhones and 3G enabled iPad’s. The third
method uses a WiFi hotspot, which is similar
to the Cell Tower Triangulation but is only
accurate to within a few hundred feet. All
iPhone OS devices (iPhone, iPod Touch and
iPad) support WiFi hotspot geolocation
services.
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Using Multitouch in an App
By default, Flash assumes that you are using
a mouse to touch the screen. This actually
works OK for many iPhone Apps and allows
you to take the same code you have developed for other Flash movies and move it into
your iPhone projects. That’s OK, but what
about those cool iPhone gestures (New!) you
see people using to swipe content? Flash can
do that, too.
For the iPhone, Flash supports the following Multitouch gestures:

1

Create a new iPhone App, apply the
appropriate development profiles and
certificates, and then save the file with
the name iPhoneMultitouch.fla.

2

Draw a rectangle on the Stage, and then
convert the rectangle into a Movie Clip
with the name myMovie.

3

Open the Actions panel.

4

Add code to import the class libraries:

◆

TransformGestureEvent.GESTURE_PAN

import flash.ui.Multitouch;

◆

TransformGestureEvent.GESTURE_ROTATE

import flash.ui.MultitouchInputMode;

◆

TransformGestureEvent.GESTURE_SWIPE

◆

TransformGestureEvent.GESTURE_ZOOM

Each gesture is used as an interactive
event in a Listener. This means that you can
take your knowledge of Listeners and quickly
apply it to iPhone Apps. The following example shows you how to add a swipe gesture
that will trigger a movie clip to fade onto the
screen.

408
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5

Set the default Alpha value for the Movie
Clip to 0:
myMovie.alpha = 0;

6

Add a listener and function that enable
the Movie Clip to fade onto the screen
(see illustration).

7

Publish and package your file into an
iPhone App and test it on your iPhone.
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